【hdu 1222】Wolf and Rabbit

There is a hill with n holes around. The holes are signed from 0 to n-1. 



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes. 
Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648). 
Output
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line. 
Sample Input
2
1 2
2 2
Sample Output
NO
YES

题目大意:
有n个洞,第一个是0,最后一个是n-1,组成一个环,狼每m个洞进去查看一次,如果有安全洞,则输出“yes”,否则输出“no"。

题解:本题的重点就在于判断n,m是否互质,即最大公约数是否是1,如果是,则输出“no”,反之“yes”。


代码:
#include<cstdio>
int main()
{
	int gcd(int a,int b);
	int T;
	long long m,n;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%lld%lld",&m,&n);
		if(gcd(m,n)==1)  printf("NO\n");
		else printf("YES\n"); 
	}
	return 0;
} 
int gcd(int a,int b)
{
	if(b==0) return a;
	return gcd(b,a%b);
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值