maxsum(dp求最大子矩阵)

Judge Info


  • Memory Limit: 32768KB
  • Case Time Limit: 3000MS
  • Time Limit: 3000MS
  • Judger: Number Only Judger


Description


Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 × 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. As an example, the maximal sub-rectangle of the array:

 0 –2 –7  0
 9  2 –6  2
-4  1 –4  1
-1  8  0 –2


is in the lower left corner:

 9 2
-4 1
-1 8


and has a sum of 15.


Input


The input consists of an N × N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N ^ 2 integers separated by whitespace (spaces and newlines). These are the N ^ 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].


Output


Output the sum of the maximal sub-rectangle.


Sample Input

4
0 –2 –7 0
 9 2 –6 2
-4 1 –4 1
–1 8 0 -2


Sample Output

15


dp觉得真是比较玄的一个东西

要解决最大子矩阵问题,首先要解决最大字段和问题。

最大字段和的状态转移方程如下:

b[j]=max{b[j-1]+a[j],a[j]},1<=j<=n

而最大子矩阵可以转换为类似问题

#include<stdio.h>
#include<string.h>
#define MAXN 105
int main()
{
    int i,j,k,n,t,sum,max;
    int a[MAXN][MAXN];
    while (scanf("%d",&n)!=EOF)
    {
        memset(a,0,sizeof(a));
        for (i=1;i<=n;++i)
        {
            for (j=1;j<=n;++j)
            {
                scanf("%d",&t);
                a[i][j]=a[i-1][j]+t;
            }
        }
        max=0;
        for (i=1;i<=n;++i)
        {
            for (j=i;j<=n;++j)
            {
                sum=0;
                for (k=1;k<=n;++k)
                {
                    t=a[j][k]-a[i-1][k];
                    sum+=t;
                    if (sum<0) sum=0;
                    if (sum>max) max=sum;
                }
            }
        }
        printf("%d\n",max);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值