并查集入门题-以POJ1611 The Suspects为例

题目:

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source

Asia Kaohsiung 2003

概述:n个学生分属m个团体,(0 < n <= 30000 , 0 <= m <= 500) 一个学生可以属于多个团体。一个学生疑似患病,则它所属的整个团体都疑似患病。已知0号学生疑似患病,以及每个团体都由哪些学生构成,求一共多少个学生疑似患病。


解法:最基础的并查集,把所有可疑的都并一块。 

Code:

 

#include<cstdio>
using namespace std;

int n,m,k,a,b;
int par[30010]={};
int total[30010] = {} ;

int get_root(int i) 
{
    if ( par[i] != i ) 
       par[i] = get_root(par[i]) ;
    return par[i] ;
}

void merge(int x,int y) 
{
   int a =     get_root(x) , b = get_root(y) ;
   if ( a == b ) return ;
   total[a] += total[b] ;
   par[b] = a ;

int main () 
{
    while ( 1 ) 
    {
        scanf("%d %d",&n,&m) ;
        if ( n == 0 && m == 0 ) return 0 ;
        for ( int i = 0 ; i < n ; ++ i) par[i] = i,total[i] = 1 ; 
        for ( int i = 0 ; i < m ; ++i ) 
        {
            scanf("%d %d",&k,&a) ;
            for ( int j = 1 ; j < k ; ++ j ) 
            {
                scanf("%d",&b) ;
                merge(a,b) ; 
            }
        }
        printf("%d\n",total[get_root(0)]) ;
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值