HDU-2709-Sumsets


Sumsets

Time Limit: 6000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3293 Accepted Submission(s): 1314


Problem Description
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input
A single line with a single integer, N.

Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input
  
  
7

Sample Output
  
  
6

题目链接:点击打开链接

思路:

设a[n]为整数n分解成2^i相加形式的分法个数。

当n为奇数时,n-1为偶数,n = 1 + n-1,分解出一个1,再分解偶数n-1,也就是a[n-1]种分法。

当n为偶数时,有两种分解方法。

1):相加的2^i中含有1。因为n为偶数,所以至少有两个1,即n = 1 + 1 + n-2,则总数为a[n-2]。

2):相加的2^i中不含1。分解的因子都是偶数,将每个分解的2^i都除以2,刚好是n/2的分解结果,

总数为a[n/2]。

总结起来就是:

如果n为奇数,a[n] = a[n-1],如果n为偶数,a[n] = a[n-2] + a[n/2]。这是一个递推过程。


AC代码:
#include<cstdio>//递推 
const int ans=1000001;
int a[ans]; 
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		a[1]=1;
		a[2]=2;
		for(int i=3; i<=n; i++)
		{
			if(i%2==1)
			{
				a[i]=a[i-1];
			}
			if(i%2==0)
			{
				a[i]=(a[i-1]+a[i/2])%1000000000;//保留最多9位数 
			}
		}
		printf("%d\n",a[n]);
	}
return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值