HDU 2709 Sumsets

题目
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

  1. 1+1+1+1+1+1+1
  2. 1+1+1+1+1+2
  3. 1+1+1+2+2
  4. 1+1+1+4
  5. 1+2+2+2
  6. 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
Input
A single line with a single integer, N.
Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
Sample Input
7
Sample Output
6

这居然是个多组输入输出!!!

题意:把一个数看成多个数相加的和,其中加数均为2^n

思路:

  1. 当输入数据为奇数时,a[n]=a[n-1],因为n=(n-1)+1,相当于给n-1分解出的每个式子+1,而单个1不可能再组合成其他数字,所以式子总数并没有变化。
  2. 当输入数据为偶数时,分两种情况,
    如果式子中含有1,相当于给n-2分解出的每个式子+1+1(因为是偶数所以必然是两个1),
    如果式子中不含1,相当于给n/2分解出的每个式子*2,两种情况加起来,a[n]=a[n-2]+a[n/2]。
#include <stdio.h>
int a[1000010];
int main()
{
	int n,i;
	a[1]=1;
	a[2]=2;
	for(i=3;i<=1000005;i++)
	{
		if(i%2==0) a[i]=(a[i-2]+a[i/2])%1000000000; 
		else a[i]=a[i-1];
	}
	while(scanf("%d",&n)!=EOF) 
	    printf("%d\n",a[n]);
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值