HDOJ-5631 Rikka with Graph

Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1058    Accepted Submission(s): 515


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number T(T30) ——The number of the testcases.

For each testcase, the first line contains a number n(n100) .

Then n+1 lines follow. Each line contains two numbers u,v , which means there is an edge between u and v.
 

Output
For each testcase, print a single number.
 

Sample Input
  
  
1 3 1 2 2 3 3 1 1 3
 

Sample Output
  
  
9
 直接枚举暴力删边就行啦!还是并查集概念。
代码:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
using namespace std;
struct s
{
    int a,b;
}p[110];
int fa[110];
int n;
int find(int x)
{
    int r=x;
    while(r!=fa[r])
    r=fa[r];
    int i=x,j;
    while(i!=r)
    {
        j=fa[i];
        fa[i]=r;
        i=j;
    }
    return r;
}
int check(int aa,int bb)
{
    int i;
    for(i=1;i<=n;i++)
    fa[i]=i;
    for(i=0;i<=n;i++)
    {
        if(i==aa||i==bb)
        continue;
        int nx=find(p[i].a);
        int ny=find(p[i].b);
        if(nx!=ny)
        fa[nx]=ny;
    }
    int cnt=0;
    for(i=1;i<=n;i++)
    if(fa[i]==i)
    cnt++;
    return cnt==1?1:0;
}
int main()
{
    int t,i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<=n;i++)
        scanf("%d%d",&p[i].a,&p[i].b);
        int ans=0;
        for(i=0;i<=n;i++)
        {
            for(j=i;j<=n;j++)
            {
                if(check(i,j))
                ans++;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值