POJ---1837 Balance【01背包】

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

SOURCE:点击打开链接


题意:给出天平有几个挂钩,给出钩码的数量与质量,要求将所有的钩码都用上使得天平平衡,问有多少种方案数。


解析:通过挂砝码天平可以处于不同的状态,所以用一个平衡度j来衡量状态,j=0时平衡,j>0时右倾,j<0时左倾,dp[i][j]表示当加上i个钩码,天平平衡度为j时的方案数。因为下标不能出现负数,所以做一个处理,极端情况下j=-7500和7500,所以右移7500个单位,变为0--15000,7500时天平平衡。

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#define MAXN 15000

int dp[20][MAXN],c[25],g[25];
int C,G;

int main(void)
{
    scanf("%d%d",&C,&G);
    memset(dp,0,sizeof(dp));
    dp[0][7500]=1;//不挂砝码时天平平衡,方案数为1
    for(int i=1; i<=C; i++)
        scanf("%d",&c[i]);
    for(int i=1; i<=G; i++)
        scanf("%d",&g[i]);
    for(int i=1; i<=G; i++)
        for(int j=375; j<=14725; j++)//从375到14725,防止出现负数或者越界
            if(dp[i-1][j])//如果dp[i-1][j]为0的话说明天平达不到这个状态,也就没有必要在不存在的状态下加钩码
                for(int k=1; k<=C; k++)
                    dp[i][j+c[k]*g[i]]+=dp[i-1][j];//将一个钩码加到一个位置后达到某个状态的方案数与未加钩码前的方案数和将钩码
    printf("%d\n",dp[G][7500]);//加到另一个地方达到同样的平衡度有关。
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值