POJ 1284 Primitive Roots【欧拉函数】

8 篇文章 0 订阅

题目来戳呀

Description

We say that integer x, 0 < x < p, is a primitive root modulo odd prime p if and only if the set { (x i mod p) | 1 <= i <= p-1 } is equal to { 1, ..., p-1 }. For example, the consecutive powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a primitive root modulo 7. 
Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p. 

Input

Each line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator.

Output

For each p, print a single number that gives the number of primitive roots in a single line.

Sample Input

23
31
79

Sample Output

10
8
24

题意:给出一个奇素数,求出它的原根的个数。

n的原根x满足条件0<x<n,并且有集合{ x^i mod n) | 1 <= i <=n-1 } 和集合{ 1, ..., n-1 }相等。

即x模n的阶等于φ(n),则称x为模n的一个原根。(其中φ(n)表示n的欧拉函数)

想法:看到某个题解说如果你知道欧拉函数这个题就不难了,那我可能看的是假的欧拉函数==原根的讲解

这一题主要用了以下定理:

1.一个数n有原根,那么它有φ(φ(n))个模n不同余的原根(n是否素数都可用)

2.所有的奇素数都是由原根的。

3.一个素数有原根,则有φ(n-1)个原根。

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
int euler(int n)
{
    int ans;
    ans=n;
    for(int i=2;i<=sqrt(n);++i)
    {
        if(n%i==0)
        {
            ans-=ans/i;
            while(n%i==0)
                n/=i;
        }
    }
    if(n>1)
    {
        ans-=ans/n;
    }
    return ans;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int m=euler(n-1);
        printf("%d\n",m);
    }
    return 0;
}

ps:被某个欢脱的人拉去做他们队的翻译,感觉好阔怕orz吓得我都不敢上网找翻译了QAQ

很气,因为不能第一反应到是欧拉函数,结果某猪说是我题做得少不知道什么是原根TAT

现在看来就是考验知识储备量的。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值