HDU 6050 Funny Function

题目来戳呀

Input

There is one integer T in the first line.
The next T lines,each line includes two integers N and M .
1<=T<=10000,1<=N,M<2^63.

Output

For each given N and M,print the answer in a single line.

Sample Input

2
2 2
3 3

Sample Output

2
33

Source

2017 Multi-University Training Contest - Team 2
题意:
求公式的值。
想法:
求法1:
矩阵快速幂
求法2:
利用斐波那契数列的线性递推公式
求法3:
打表找规律

#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
typedef long long ll;
const int mod=1e9+7;
ll qwod(ll a,ll b)
{
    ll ret=1;
    a%=mod;
    while(b>0)
    {
        if(b&1)
            ret=(ret*a)%mod;
        a=(a*a)%mod;
        b>>=1;

    }
    return ret;
}
ll inv(ll x)
{
    return qwod(x,mod-2);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
       ll n,m,ans;
       scanf("%lld %lld",&n,&m);
       if(n&1)
       {
           ans=(qwod(qwod(2,n)-1,m-1)*2%mod+1)*inv(3)%mod;

       }
       else
       {
           ans=qwod(qwod(2,n)-1,m-1)*2%mod*inv(3)%mod;

       }
       printf("%lld\n",ans);
    }
    return 0;
}

ps:线性递推什么的高中真的学过吗○| ̄|_

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值