Input
There is one integer T in the first line.
The next T lines,each line includes two integers N and M .
1<=T<=10000,1<=N,M<2^63.
Output
For each given N and M,print the answer in a single line.
Sample Input
2
2 2
3 3
Sample Output
2
33
Source
2017 Multi-University Training Contest - Team 2
题意:
求公式的值。
想法:
求法1:
矩阵快速幂
求法2:
利用斐波那契数列的线性递推公式
求法3:
打表找规律
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
typedef long long ll;
const int mod=1e9+7;
ll qwod(ll a,ll b)
{
ll ret=1;
a%=mod;
while(b>0)
{
if(b&1)
ret=(ret*a)%mod;
a=(a*a)%mod;
b>>=1;
}
return ret;
}
ll inv(ll x)
{
return qwod(x,mod-2);
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
ll n,m,ans;
scanf("%lld %lld",&n,&m);
if(n&1)
{
ans=(qwod(qwod(2,n)-1,m-1)*2%mod+1)*inv(3)%mod;
}
else
{
ans=qwod(qwod(2,n)-1,m-1)*2%mod*inv(3)%mod;
}
printf("%lld\n",ans);
}
return 0;
}
ps:线性递推什么的高中真的学过吗○| ̄|_