HDU 6097 Mindis【计算几何】

题目来戳呀

Problem Description

The center coordinate of the circle C is O, the coordinate of O is (0,0) , and the radius is r.
P and Q are two points not outside the circle, and PO = QO.
You need to find a point D on the circle, which makes PD+QD minimum.
Output minimum distance sum.

Input

The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with r : the radius of the circle C.
Next two line each line contains two integers x , y denotes the coordinate of P and Q.

Limits
T≤500000
−100≤x,y≤100
1≤r≤100

Output

For each case output one line denotes the answer.
The answer will be checked correct if its absolute or relative error doesn’t exceed 10−6.
Formally, let your answer be a, and the jury’s answer be b. Your answer is considered correct if |a−b|max(1,b)≤10−6.

Sample Input

4
4
4 0
0 4
4
0 3
3 0
4
0 2
2 0
4
0 1
1 0

Sample Output

5.6568543
5.6568543
5.8945030
6.7359174

Source

2017 Multi-University Training Contest - Team 6

题意:

给你一个圆心为o半径为r的圆,p,q两点在园内或圆上,op=oq,找到一个在圆上的点d,使得pd+qd的值最小。输出这个pd+qd。

想法:

预备知识:有一个你不知道就做不出来的知识点:)(用了这个小伙伴的图
在平面上,给定了半径为r的圆O,对于任意点P,在射线OP上取一点P′,使得OP•OP′= r2 ,这把点P变为点P的变换叫做反演变换,点P与点P′叫做互为反演点。
首先对p点做反演点p1,由反演点定义易得 PODDOP (两边成比例,夹角相等),所以 OPOD = ODOP = PDDP

我们发现PD可以转化成求PD’的值,即PD=PD’×相似比
同理,做出Q的反演点Q’,QD=Q’D×相似比
PD+QD=相似比×(P’D+Q’D),所以接下来的重点就是求P’D+Q’D

连接P’D’.
1.若P’D’与圆有交点,则交点就是D’。
若D不是这个交点,而是圆上其他位置上的点,P’DQ’就会构成三角形,根据三角形的两边之和大于第三边,我们易得只有D是交点时,P’D+Q’D会最短。

这里写图片描述
2.若P’Q’与圆无交点,则P’D’中垂线与圆的交点是D
将P’、Q’看作椭圆的两个焦点,P’Q’的中点是原点,P’D’中垂线是短轴
因为在 以 P’ 和 Q’ 为焦点的椭圆上的任意一点到 P’ 和 Q’ 的距离之和 d 相等,为 2a;而在既能在圆上又能在椭圆上的只有椭圆与圆的切点,即中垂线与圆的交点。
这里写图片描述

#include<bits/stdc++.h>
using namespace std;
const double eps=1e-8;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double r,xp,yp,xq,yq;
        scanf("%lf%lf%lf%lf%lf",&r,&xp,&yp,&xq,&yq);
        double op=sqrt(pow(xp,2)+pow(yp,2));
        if(fabs(op)<eps)///p q两个点无限相交的时候
        {
            printf("%.7f\n",2*r);
        }
        else
        {
            double ans;
            double scale=r*r/(op*op);///相似比
            double xp1=xp*scale,yp1=yp*scale,xq1=xq*scale,yq1=yq*scale;
            double midx=(xp1+xq1)/2,midy=(yp1+yq1)/2;
            double mid_o=sqrt(pow(midx,2)+pow(midy,2));
            if(mid_o<=r)///直线与圆相交 D是交点
            {
                double p1q1=sqrt(pow(xp1-xq1,2)+pow(yp1-yq1,2));
                ans=d1*op/r;
            }
            else///切点在之外 D就是中垂线与圆的交点
            {
                double k=r/mid_o;
                double newmidx=k*midx,newmidy=k*midy;
                ans=2*sqrt(pow(newmidx-xp,2)+pow(newmidy-yp,2));
            }
            printf("%.7f\n",ans);
        }
    }
    return 0;
}

ps:呜啊 这个真的就是纯几何题了吧QAQ 之前没接触过反演,看到有人说初中知识,怀疑我的初中真的存在过吗QAQ

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值