POJ 2976 Dropping tests【分数规划】【二分搜索】

题目来戳呀

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

100ni=1aini=1bi

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

题意

n门课程,给出每门的得分a及每门的满分b,求得分之和/满分之和的最大值。同时还给出k,可以去掉k门课程来保证更大的得分平均值。

想法

就是分数规划啊+_+
令r = ∑a[i] * x[i] / (b[i] * x[i]) 则必然∑a[i] * x[i] - ∑b[i] * x[i] * r= 0;(条件1)
并且任意的 ∑a[i] * x[i] - ∑b[i] * x[i] * max(r) <= 0 (条件2,只有当∑a[i] * x[i] / (b[i] * x[i]) = max(r) 条件2中等号才成立)
然后枚举r就可以了。
注意要排序,因为要拿走k 门(注意不是求k门。)

#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
double a[1100],b[1100],f[1100];;
const double acc=1e-7;
int main()
{
    int n,k;
    double mid,ans;
    while(~scanf("%d%d",&n,&k))
    {
        if(n==0&&k==0)break;
        for(int i=0; i<n; i++)
            scanf("%lf",&a[i]);
        for(int i=0; i<n; i++)
            scanf("%lf",&b[i]);
        double l=0.0,r=1.0;
        while(r-l>acc)
        {
            mid=(l+r)*1.0/2;
            for(int i=0; i<n; i++)
            {
                f[i]=a[i]-mid*b[i];
            }
            sort(f,f+n);
            ans=0;
            for(int j=k; j<n; ++j)
            {///逃课k门,成绩是n-k门
                ans+=f[j];
            }
            if(ans>0)
                l=mid;
            else
                r=mid;
        }
        printf("%.f\n",mid*100);///mid才是我们要的答案 不是ans+_+
    }
    return 0;
}

ps:算了算了 身体好了再补吧 头疼的要炸裂QAQ

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值