poj 2976 Dropping tests 01分数规划 二分+Dinkelbach算法

Dropping tests

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18825 Accepted: 6498

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).


题意:

       给你n个物品,和拿到这个物品可以获得的权值和要付出的代价。现在你最多可以去掉k个物品不拿,问你可以拿到的最大价值比是多少,(即令总价值/总代价最大)

 

做法:

       可以说是01分数规划的入门级题目了吧,发现这个知识点的时候稍微惊讶了一下,正好是之前没做出来而且觉得解法很神奇的一道题。总的来说就是在这个最有的比值上做文章(因为你事先并不知道哪些要去掉哪些不需要)。如果你要求一个最大,即列一个式子f(x)=c_{i}-x*v_{i},如果f(x)>0即x可以更大,令f(x)更小,那么就还有一个更优的解,然后不断二分就好,这里还有一种更高效的迭代的方法。


二分代码:79ms

    

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
typedef long long ll;
const int maxn=1005;
const double eps=1e-4;
int n,k;
ll a[maxn],b[maxn];
int ck(double mid){
    double now=0,tmp[maxn];
    for(int i=1;i<=n;i++){
        tmp[i]=(double)a[i]-b[i]*1.0*mid;
    }
    sort(tmp+1,tmp+1+n);
    for(int i=k+1;i<=n;i++){
        now+=tmp[i];
    }
    return now>-eps;
}
void read(){
    for(int i=1;i<=n;i++)
            scanf("%lld",&a[i]);
        for(int i=1;i<=n;i++)
            scanf("%lld",&b[i]);
}
int main(){
    while(~scanf("%d%d",&n,&k)){
        if(n==0&&k==0) break;
        read();
        double l=0,r=1.0,mid;
        while(r-l>eps){
            mid=(l+r)/2;
            if(ck(mid)) l=mid;
            else r=mid;
        }
        printf("%.f\n",mid*100);
    }
    return 0;
}

Dinkelbach代码如下:

 32ms

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
typedef long long ll;
const int maxn=1005;
const double eps=1e-4;
int n,k;
struct node{
    ll a,b;
    double d;
}e[maxn];
bool cmp(node a,node b){
    return a.d<b.d;
}
double ck(double mid){
    double nowa=0,nowb=0;
    for(int i=1;i<=n;i++){
        e[i].d=(double)e[i].a-e[i].b*1.0*mid;
    }
    sort(e+1,e+1+n,cmp);
    for(int i=k+1;i<=n;i++){
        nowa+=e[i].a;
        nowb+=e[i].b;
    }
    return nowa/nowb;
}
void read(){
    for(int i=1;i<=n;i++)
            scanf("%lld",&e[i].a);
        for(int i=1;i<=n;i++)
            scanf("%lld",&e[i].b);
}
int main(){
    while(~scanf("%d%d",&n,&k)){
        if(n==0&&k==0) break;
        read();
        double a=0,b;
        while(1){
            b=ck(a);
            if(fabs(a-b)<eps) break;;
            a=b;
        }
        printf("%.f\n",a*100);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值