【POJ】2976 Dropping tests(二分)

【POJ】2976 Dropping tests(二分)

【题目链接】http://poj.org/problem?id=2976


题目内容

    In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be
Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.
Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

题目大意

给你两个数组a[],b[],分别代表每次测试得到的分和总分,可以除掉其中的k对,要使sum(a[i])/sum(b[i])*100,也就是剩下的占分比例最大。


解题思路

一开始想用贪心,但是找不出合适的规律尤其是数据中包括0,所以放弃了233.
直接二分删除后的sum(a)/sum(b),减去对这个答案贡献最小的几对,看能不能取到这个答案,在我们要找的最终答案的左侧都是可以取到的,右侧都不能。注意最后输出时四舍五入。


AC代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<string>
#include<algorithm>
#include<math.h>
#include<limits.h>
#include<stack>
#include<queue>
#define LL long long
using namespace std;
struct node
{
    LL a;
    LL b;
    double c;//cJ就代表这组数据对答案的贡献

} p[1005];
bool cmp(node x,node y)
{
    return x.c<y.c;
}

int main()
{
    int n,k;
    while(scanf("%d%d",&n,&k)!=EOF&&!(n==0&&k==0))
    {

        for(int i=0;i<n;i++)
        {
           scanf("%lld",&p[i].a);
        }
        for(int i=0;i<n;i++)
        {
           scanf("%lld",&p[i].b);
        }
        double left=0.0,right=1.1,mid,ans,x,y;
        while(fabs(right-left)>1e-8)
        {
            mid=(right+left)/2;
            for(int i=0;i<n;i++)
            {
               p[i].c=p[i].a-(double)p[i].b*mid;//a中超出b*mid的那部分就是这组数据对最终结果能造成的影响,正数是提高,负数是减少。
            }
            sort(p,p+n,cmp);
            ans=0;
            for(int i=k;i<n;i++)
            {
                ans+=p[i].c;
            }
            if(ans>=0)
                left=mid;
            else right=mid;
        }
        printf("%.0f\n",100*left);//浮点数输出会自动四舍五入
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值