2164 Bincomial Coeffcients(组合数求模)

2164 Bincomial Coeffcients(组合数求模)

Problem Description

这里写图片描述

Input

这里写图片描述

Output

这里写图片描述

Sample Input

3
1 1
10 2
954 723

Sample Output

1
45
3557658

解题思路:

1.em……..差点把队友坑死,第一反应时Lucas定理,二话没说就把模板打上了,但是Lucas要求模的必须是个素数,所以就尴尬了。打比赛还是不能慌,还是要仔细思考才可以
2.由于数据范围极小,所以可以直接根据公式这里写图片描述打表求解

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<memory.h>
#define M 10000003
using namespace std;
typedef long long LL;
LL a[1005][1005];
int main() {
    int n,x,y;
    memset(a,0,sizeof(a));
    for(int i=0; i<=1000; i++) {
        a[i][0]=1;
        a[i][i]=1;
    }
    for(int i=2; i<=1000; i++) {
        for(int j=1; j<i; j++) {
            a[i][j]=(a[i-1][j]%M+a[i-1][j-1]%M)%M;
        }
    }
    cin>>n;
    for(int i=0; i<n; i++) {
        cin>>x>>y;
        cout<<a[x][y]<<endl;
    }
    return 0;
}


/***************************************************
User name: dlili
Result: Accepted
Take time: 40ms
Take Memory: 1964KB
Submit time: 2018-04-10 23:22:47
****************************************************/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值