题目1019:简单计算器

题目1019:简单计算器

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:4981

解决:1863

题目描述:
    读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。
输入:
    测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。
输出:
    对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。
样例输入:
1 + 2
4 + 2 * 5 - 7 / 11
0
样例输出:
3.00
13.36
<strong><span style="font-size:14px;">代码如下:先分割加法,再分割减法,最后分割乘法递归(将除法换算成乘法)</span></strong>
import java.util.Scanner;
import java.util.concurrent.CountDownLatch;

public class Main {
	public static void main(String arg[]){
		Scanner sc = new Scanner(System.in);
		while(sc.hasNext()){
			String s = sc.nextLine();
			if(s.equals("0")) break;
			s = s.replace(" ", "");
			String[] s1 = s.split("\\+");
			double total = 0;
			for(int i=0;i<s1.length;i++)
			{
				total +=  Min(s1[i]);
			}
			System.out.printf("%.2f\n",total);
		}
		
		
	}

	private static double Min(String string) {
		String[] s = string.split("\\-");
		double total = 0;
		for(int i=0;i<s.length;i++)
		{
			if(i==0)
			 total = mul(s[i]);
			else total -= mul(s[i]);
		}
		return total;
	}

	private static double mul(String string) {
		string=string.replace("/", "*A");
		String[] s = string.split("[*]");
		double total = 1;
		for(int i=0;i<s.length;i++)
		{
			Double x;
			if(s[i].charAt(0)=='A') 
				{
				s[i]=s[i].replace("A", "");
				x = new Double(s[i]);
				x = 1.0/x;
				}
			else {
				x = new Double(s[i]);
			}
				
			total *= x;
			
		}
		return total;
	}
	
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值