题目1041:Simple Sorting

题目1041:Simple Sorting

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:3943

解决:1466

题目描述:

You are given an unsorted array of integer numbers. Your task is to sort this array and kill possible duplicated elements occurring in it.

输入:

For each case, the first line of the input contains an integer number N representing the quantity of numbers in this array(1≤N≤1000). Next N lines contain N integer numbers(one number per each line) of the original array.

输出:

For each case ,outtput file should contain at most N numbers sorted in ascending order. Every number in the output file should occur only once.

样例输入:
6
8 8 7 3 7 7
样例输出:
3 7 8


参考代码:


import java.util.ArrayList;


import java.util.Collections;
import java.util.Scanner;


public class Main {
	public static void main(String arg[]){


		Scanner sc = new Scanner(System.in);
		while(sc.hasNext()){
			int num = sc.nextInt();
			ArrayList<Integer> count = new ArrayList<Integer>();
			for(int i=0;i<num;i++){
				
				Integer newnum = sc.nextInt();
				if(count.contains(newnum)==false) count.add(newnum);
			}
			
			Collections.sort(count);
			System.out.println(count.toString()
					.replace("[","")
					.replace("]", "")
					.replace(",", ""));
			
		}		
	}	
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值