1013. Battle Over Cities (25)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0
并查集或DFS都试了下, DFS思路是从一个结点遍历图,没有遍历到的地方即另一个图需要连通;另外DFS用邻接表里用list会超时;
/**并查集**/
#include <iostream>
#define MAX 1005

using namespace std;

struct NODE{
    int x;
    int y;
}way[MAX*MAX];
int pre[MAX];
int Find(int x)
{
    return pre[x]==x ? x : pre[x]=Find(pre[x]);
}

void Union(int x, int y)
{
    int u, v;
    u = Find(x);
    v = Find(y);
    if(u==v)
        return ;
    pre[v] = u;
}

int main()
{
    int n, m, k;
    int city;
    cin >> n >> m >> k;
    for(int i=0; i<m; i++)
    {
        cin >> way[i].x >> way[i].y;
    }
    while(k--)
    {
        cin >> city;
        for(int i=1; i<=n; i++)
            pre[i] = i;
        for(int i=0; i<m; i++)
        {
            if(way[i].x!=city && way[i].y!=city)//对除输入以外的城市进行union
                Union(way[i].x, way[i].y);
        }
        int num = 0;
        for(int i=1; i<=n; i++)
            if(pre[i]==i && pre[i]!=city)//完成union后为根的city需要连通
                num++;
        cout << num-1 << endl;//总连通数量为需要连通城市-1
    }
    return 0;
}


#include <iostream>
#include <list>
#include <vector>
#include <iterator>
#define MAX 1005
using namespace std;

struct Node{
    vector<int> v;
    bool known;
}city[MAX];

int way, cityn, x;
void dfs(int a)
{
    vector<int>::iterator it;
    city[a].known = true;
    for(it=city[a].v.begin(); it!=city[a].v.end(); it++)
    {
        if(!city[*it].known)
            dfs(*it);
    }
}

void init()
{
    int u, v;
    for(int i=0; i<way; i++)
    {
        cin >> u >> v;
        city[u].v.push_back(v);
        city[v].v.push_back(u);
    }
}

int main()
{
    int k;
    int num = 0;
    cin >> cityn >> way >> k;
    init();
    while(k--)
    {
        cin >> x;
        num = 0;
        for(int i=1; i<=cityn; i++)
            city[i].known = false;
        city[x].known = true;
        for(int i=1; i<=cityn; i++)
        {
            if(!city[i].known)
            {
                dfs(i);
                num++;
            }
        }
        cout << num-1 << endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值