1040. Longest Symmetric String (25)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given "Is PAT&TAP symmetric?", the longest symmetric sub-string is "s PAT&TAP s", hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:
Is PAT&TAP symmetric?
Sample Output:
11
有bbaabb和bbaaabb两种情况要考虑

#include <iostream>
#include <string>

using namespace std;


int longest(string n)
{
    int maxlen = 1, temp1, temp2;
    for(int i=1; i<n.size(); i++)
    {
        temp1 = 0;
        for(int j=0; i+j<n.size() && i-1-j>=0 && n[i+j]==n[i-1-j];j++)
        {
            temp1 += 2;
        }
        temp2 = 1;
        for(int j=1; (i+j)<n.size() && (i-j)>=0 && n[i-j]==n[i+j]; j++)
        {
            temp2 += 2;
        }
        if(max(temp1, temp2) > maxlen)
            maxlen = max(temp1, temp2);
    }
    return maxlen;
}
int main()
{
    string n;
    getline(cin, n);
    cout << longest(n);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值