【PAT甲级】1040 Longest Symmetric String (25)(Manacher)

34 篇文章 0 订阅

题目链接

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given "Is PAT&TAP symmetric?", the longest symmetric sub-string is "s PAT&TAP s", hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

思路:最长回文子串,用Manacher算法,分析见:Manacher 算法(求字符串的回文子串的最大长度)

代码:

#include <iostream>
#include <sstream>
#include <string>
#include <cstdio>
#include <queue>
#include <cstring>
#include <map>
#include <cstdlib>
#include <stack>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define mem(a,n) memset(a,n,sizeof(a))
#define DBGS() cout<<"START\n"
#define DBGE() cout<<"END\n"
const int N = 1e5+5;
const ll INF = 0x3f3f3f3f;
const double eps=1e-4;

int p[N];
char s[N],t[N];
int init() {
    int len=strlen(s);
    t[0]='$',t[1]='#';
    int j=2;
    for(int i=0; i<len; i++) {
        t[j++]=s[i];
        t[j++]='#';
    }
    s[j]='\0';
    return j;
}
void manacher() {
    int len=init();
    int maxlen=0,mx=0,id;
    for(int i=1; i<len; i++) {
        if(i<mx)
            p[i]=min(p[id*2-i],mx-i);
        else
            p[i]=1;
        while(t[i-p[i]]==t[i+p[i]])
            p[i]++;
        if(mx<i+p[i]) {
            id=i;
            mx=i+p[i];
        }
        maxlen=max(maxlen,p[i]-1);
    }
    printf("%d\n",maxlen);
}
int main() {
    fgets(s,sizeof(s),stdin);
    manacher();
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值