PAT-python-1042 Shuffling Machine

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, …, S13,
H1, H2, …, H13,
C1, C2, …, C13,
D1, D2, …, D13,
J1, J2
where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:
2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:
S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C5


解法

简单来说就是:先输入一个洗牌次数,然后输入洗牌的顺序。以示例为例,第一张牌是S1,先放到36号位,发现36号位的值是5,所以再拿到5号位,因此第5位(1-based)是S1。无脑模拟即可。

n = int(input())
nums = [int(i) for i in input().strip().split()]
result = {}
for i in range(len(nums)):
    h = i // 13
    t = str(i % 13 + 1)
    # 用一个字典计算牌的标号
    dic_h = {0:'S', 1:'H', 2:'C', 3:'D', 4:'J'} 
    k = dic_h[h] + t
    # 显然n=0不用洗牌
    if n == 0:
        result[k] = nums[i]
        continue
    cnt = n - 1
    # cnt记录循环次数,一开始是用原来的index,在nums里跳一次就少一次循环
    # 注意是1-based的输入,所以跳的时候要-1
    tmp = nums[i] - 1
    while cnt > 0:
        tmp = nums[tmp] - 1
        cnt -= 1
    result[k] = tmp
# 以最终获得的位置编号升序排序,然后把牌的编号取出来就行了
ans = sorted(result.items(), key=lambda i:i[1])
ans2 = [i[0] for i in ans]
print(" ".join(ans2))
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值