10-排序5 PAT Judge 分数 25

这篇文章描述了一个程序任务,要求根据用户对多项编程问题的提交成绩(包括是否通过编译)生成PAT排名列表。排名依据总分、解决问题的数量以及编译状态进行排序。
摘要由CSDN通过智能技术生成

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤104), the total number of users, K (≤5), the total number of problems, and M (≤105), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

要注意很多细节,详细看注释,注意排名中的人提交的某题没有通过编译,则显示0

#include <bits/stdc++.h>
using namespace std;
int n,k,m;
int p[6];
struct stu{
	int id;
	int get[6];		//get0存储完美解决数量 
	int sum;
};
stu s[10005];
bool cmp(stu a,stu b){
	if(a.sum == -1)return false;								
	else if(b.sum == -1)return true;								//先看有没有编译通过的 
	else if(a.sum != b.sum )return a.sum > b.sum ;					//再看总分 
	else if(a.get[0] != b.get[0])return a.get[0] > b.get[0];		//再看完美通过数量 
	else return a.id < b.id ;										//再看ID 
}
void print(int x){
	if(x > 9999)cout<<x;
	else if(x > 999)cout<<"0"<<x;
	else if(x > 99)cout<<"00"<<x;
	else if(x>9)cout<<"000"<<x;
	else cout<<"0000"<<x;
}
int main()
{
	cin>>n>>k>>m;
	for(int i = 1;i<=n;i++){
		for(int j = 1;j<=k;j++){
			s[i].get[j] = -2;							//-2为没有提交过 
		}
		s[i].sum = 0;
		s[i].get[0] = 0;
		s[i].id = i;
	}
	for(int i = 1;i<=k;i++)cin>>p[i];
	for(int i = 1;i<=m;i++){
		int a,b,c;
		cin>>a>>b>>c;
		if(s[a].get[b] < c)s[a].get[b] = c;
	}
	int cnt = 0;													//编译通过数量 
	for(int i = 1;i<=n;i++){
		int flag = 0;
		for(int j = 1;j<=k;j++){
			if(s[i].get[j]>=0){
				flag = 1;
				s[i].sum +=s[i].get[j];
				if(s[i].get[j] == p[j])s[i].get[0]++;
			}
		}
		if(!flag)s[i].sum = -1;
		else cnt++;
	}
	sort(s+1,s+n+1,cmp);
	int mc = 1;
	s[0].sum = 0;
	for(int i = 1;i<=cnt;i++){
		if(s[i].sum != s[i-1].sum )mc = i;
		cout<<mc<<" ";
		print(s[i].id );
		cout<<" "<<s[i].sum ;
		for(int j = 1;j<=k;j++){
			cout<<" ";
			if(s[i].get[j] == -2)cout<<"-";
			else if(s[i].get[j] == -1)cout<<"0";		//排名中的人无提交的题输出-,有提交不通过输出0 
			else cout<<s[i].get[j];
		}
		cout<<endl;
	}
	return 0;
}

  • 13
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值