10-排序6 Sort with Swap(0, i) 分数 25

Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤105) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

思路:

读入数组同时记录其反函数,即值为i的数下标为h[i]

当前a[0]==0时,进行检查,查找数组中是否有a[i]!=i,并记录当前检查到第几个数(这样时间复杂度是O(n),不然会超时,可自行尝试)

然后进行a[i]与a[0]的交换。

当前a[0]!=0时,找到0的下标(h[0]),让数h[0]与数0进行交换

#include <bits/stdc++.h>
using namespace std;
int n,k,m,cnt = 0;
int a[100005];
int h[100005];
int checkk = 0;
bool check(){
	for(int i = checkk;i<n;i++){
		if(a[i] != i){
			checkk = i;
			a[0] = a[i];
			a[i] = 0;
			h[0] = i;
			h[a[0]] = 0;
			cnt++;
			return false;
		}
	}
	return true;
}
int main()
{
	cin>>n;
	for(int i = 0;i<n;i++){
		cin>>a[i];
		h[a[i]] = i;
	}
	while(1){
		if(a[0] == 0){
			if(check())break;
		}else {
			int d = h[0];
			int dd = h[d];
			a[d] = d;
			a[dd] = 0;
			h[a[d]] = d;
			h[0] = dd;
			cnt++;
		}
	}
	cout<<cnt;
	return 0;
}

  • 24
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值