POJ - 3111

Demy has n jewels. Each of her jewels has some value vi and weight wi.
Since her husband John got broke after recent financial crises, Demy has decided to sell some jewels. She has decided that she would keep k best jewels for herself. She decided to keep such jewels that their specific value is as large as possible. That is, denote the specific value of some set of jewels S = {i1, i2, …, ik} as
Demy would like to select such k jewels that their specific value is maximal possible. Help her to do so.

Input

The first line of the input file contains n — the number of jewels Demy got, and k — the number of jewels she would like to keep (1 ≤ k ≤ n ≤ 100 000).
The following n lines contain two integer numbers each — vi and wi (0 ≤ vi ≤ 106, 1 ≤ wi ≤ 106, both the sum of all vi and the sum of all wi do not exceed 107).

Output

Output k numbers — the numbers of jewels Demy must keep. If there are several solutions, output any one.

Sample Input

3 2
1 1
1 2
1 3

Sample Output

1 2

有n件珠宝,要从中挑出k件,使得总价值/总重量最大。
s=∑v/∑w
s*(w1+w2+…+wk)=v1+v2+…+vk
则可以二分查找最后结果中珠宝的平均价值比s,分别求盈余p=v-s*w,判断盈余最多的k项之和是否大于0,找出s最大时的前k项,即所求数列

#include <algorithm>
#include <stdio.h>
using namespace std;
struct node{
    int num;
    double p,v,w;
}a[100001];
bool cmp(node x,node y){
    return x.p>y.p;
}
int main()
{
    int k,n,i;
    double high,low,mid,t,x,y;
    int r[100001];
    while((scanf("%d %d",&n,&k))!=EOF){
        high=10000000.0;
        for(i=0;i<n;i++){
            scanf("%lf %lf",&x,&y);
            a[i].num=i+1;
            a[i].v=x;
            a[i].w=y;
            //high+=x;
        }
        low=0.0;
        while((high-low)>1e-8){
            mid=(low+high)/2;
            for(i=0;i<n;i++){
                a[i].p=a[i].v-a[i].w*mid;
            }
            sort(a,a+n,cmp);
            t=0.0;
            for(i=0;i<k;i++){
                t+=a[i].p;
                r[i]=a[i].num;
            }
            if(t<0.0){
                high=mid;
            }else{
                low=mid;
            }
        }
        for(i=0;i<k;i++){
            printf("%d",r[i]);
            if(i<k-1){
                printf(" ");
            }
        }
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值