hdu1060 求n^n第一位数 数学java

16 篇文章 0 订阅
15 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=1060

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21639    Accepted Submission(s): 8356


 

Problem Description

Given a positive integer N, you should output the leftmost digit of N^N.

 

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

 

 

Output

For each test case, you should output the leftmost digit of N^N.

 

 

Sample Input

 

2 3 4

 

 

Sample Output

 

2 2

Hint

In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

import java.util.Scanner;


public class Main {
	@SuppressWarnings("resource")
	public static void main(String[] args) {
	Scanner sc = new Scanner(System.in);
	while (sc.hasNext()) {
		double n = sc.nextDouble();
		double tmp = n * Math.log10((double) (n));
		//pow=n^n 
		//log10(pow)=n*log10(n) 
		//pow=10^(n*log10(n))
		//求出tmp=n*log10(n)
		//10^n第一位都是1,所以只和tmp的小数有关;
		double res = tmp - Math.floor(tmp);
		System.out.println((int) Math.pow(10.0, res));
		}
	}
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值