[kuangbin]专题一 简单搜索 F - Prime Path

Prime Path

  POJ - 3126


The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033 
1733 
3733 
3739 
3779 
8779 
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.
Sample Input
3
1033 8179
1373 8017
1033 1033
Sample Output
6
7
0


题意:两个素数n,m. from n to m. 每次只能换一个数字,每次换完必须还是素质,问最少次数。

思路:偶数pass,千位不能为0,素数判断.然后bfs搜就是了。

ACcode:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
using namespace std;
int n,m;
struct node{
	int x;
	int s;
};
int book[15000]; 
bool judge_prime(int x)
{
	if(x==2 || x==3)
	return true;
	else if(x<=1 || x%2==0)
	return false;
	else if(x>3)
	{
		for(int i=3,j=sqrt(x);i<=j;i+=2)
			if(x%i==0)
			return false;
		return true;
	}
} 
int bfs()
{
	node now,next;
	queue<node> q;
	now.x=n;
	now.s=0;
	book[n]=1;
	q.push(now);
	while(!q.empty())
	{
		now=q.front();
		q.pop();
		int X=now.x; 
		if(X==m) return now.s;
	    for(int i = 1; i <= 9; i += 2) //个位  
        {  
            int s = X / 10 * 10 + i;  
            if(s != X && !book[s] && judge_prime(s))  
            {  
                book[s] = 1;   
                next.x = s;  
                next.s = now.s + 1;  
                q.push(next);  
            }  
        }  
        for(int i = 0; i <= 9; i++) //十位  
        {  
            int s = X / 100 * 100 + i * 10 + X % 10;  
            if(s != X && !book[s] && judge_prime(s))  
            {  
                book[s] = 1;   
                next.x = s;  
                next.s = now.s + 1;  
                q.push(next); 
            }  
        }  
        for(int i = 0; i <= 9; i++) //百位  
        {  
            int s = X / 1000 * 1000 + i * 100 + X % 100;  
            if(s != X && !book[s] && judge_prime(s))  
            {  
                book[s] = 1;   
                next.x = s;  
                next.s = now.s + 1;  
               q.push(next); 
            }  
        }  
        for(int i = 1; i <= 9; i++) //千位  
        {  
            int s = i * 1000 + X % 1000;  
            if(s != X && !book[s] && judge_prime(s))  
            {  
                book[s] = 1;   
                next.x = s;  
                next.s = now.s + 1;  
                q.push(next); 
            }  
        }  
		
	}
	return -1;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		memset(book,0,sizeof(book));
		int ans=bfs();
		if(ans!=-1)
		printf("%d\n",ans);
		else
		printf("Impossible\n");
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值