A - Bi-shoe and Phi-shoe
Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu
Submit Status
Description
Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to Go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,
Score of a bamboo = Φ (bamboo’s length)
(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.
The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.
Input
Input starts with an integer T (≤ 100), denoting the number of test cases.
Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].
Output
For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.
Sample Input
3
5
1 2 3 4 5
6
10 11 12 13 14 15
2
1 1
Sample Output
Case 1: 22 Xukha
Case 2: 88 Xukha
Case 3: 4 Xukha
题解:
这题打欧拉函数表,二分搜索也可以,时间复杂度高。
有一个定理素数p的欧拉函数值是p-1,为了保证欧拉函数值大于等于幸运数字,我们从幸运数字开始往上找,找到第一个素数就加上和。
代码:
#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e5+10;
typedef long long LL;
const int MAXN = 1e6+10;
bool notprime[MAXN];
void init()
{
memset(notprime, false, sizeof(notprime));
notprime[0] = notprime[1] = true;
for (int i = 2; i < MAXN; i++)
{
if (!notprime[i])
{
if (i > MAXN / i) // 阻止后边i * i溢出(或者i,j用long long)
{
continue;
}
// 直接从i * i开始就可以,小于i倍的已经筛选过了
for (int j = i * i; j < MAXN; j += i)
{
notprime[j] = true;
}
}
}
}
int main()
{
int T;
scanf("%d",&T);
int n;
init();
int ks=1;
while(T--)
{
scanf("%d",&n);
LL sum=0;
LL tmp;
for(int i=0;i<n;i++)
{
scanf("%lld",&tmp);
tmp++;
while(notprime[tmp])
{
tmp++;
}
//cout<<tmp<<" ";
sum+=tmp;
}
printf("Case %d: %lld Xukha\n",ks++,sum);
}
return 0;
}