kuangbin 简单搜索 E

E - Find The Multiple

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111

题解:

bfs一直超时。
后来换dfs了,大佬的博客说位数最多19。
具体为什么是19位下次再研究。

代码:

#include <iostream>
#include <cstdio>
#include <queue>

using namespace std;
int n;
typedef long long LL;

/*LL bfs()
{
   queue<LL> que;
   que.push(1);
   while(que.size())
   {
       LL tmp = que.front();
       que.pop();
       if(tmp%n==0)
       {
           return tmp;
       }
       que.push(tmp*10);
       que.push(tmp*10+1);
   }
}*/
bool flag=0;
void dfs(int num,LL tmp)
{
    if(num>19||flag==1) return;

    if(tmp%n==0)
    {
        flag=1;
        cout<<tmp<<endl;
        return;
    }

    dfs(num+1,10*tmp);
    dfs(num+1,10*tmp+1);


}

int main()
{
    while(~scanf("%d",&n)&&n)
    {
        flag=0;
        dfs(1,1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值