HDOJ 1896 Stones (踢石头,优先队列)

HDOJ 1896 Stones 
Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first. 
 

Input

In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it. 
 

Output

Just output one line for one test case, as described in the Description. 
 

Sample Input

      
      
2 2 1 5 2 4 2 1 5 6 6
 

Sample Output

      
      
11 12
给你n个石头的位置,以及每块石头可以踢多远,每当碰到奇数个石头踢,碰到偶数个石头跳过去,问最后一块石头被踢后的最远位置
可以定义一个结构体,分别存储石头现在的位置和能能出去的距离到优先队列中,然后每次取 最小的 ,如果取得是偶数个就不动,取得是奇数个就要更新该石头的位置并重新存到优先队列中,直到队列空,输出最后一个石头的位置
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
struct Stone{
    int x;    
    int y;    
};//定义结构体
bool operator<( Stone a, Stone b )
{
    if( a.x== b.x ) return a.y > b.y;  
    return a.x > b.x;   
}  //队列排列顺序
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        int i ;
        priority_queue<Stone>que; //优先队列   
        scanf("%d",&n);
        Stone tmp;
        for(i =0;i< n ; i++ )
        {
            scanf("%d%d",&tmp.x,&tmp.y);
            que.push(tmp);
        }
        int sum =1;
        while(!que.empty())
        {
        tmp = que.top();
            que.pop();
            if(sum%2)
            {
                tmp . x+=tmp.y;
                que.push(tmp);
            }
            sum++;
        }
        printf("%d\n",tmp.x);
    }
  
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值