杭电 4006 The kth great number(优先队列)

Time Limit:1000MS     Memory Limit:65768KB     64bit IO Format:%I64d & %I64u

Description

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
 

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
 

Output

The output consists of one integer representing the largest number of islands that all lie on one line. 
 

Sample Input

      
      
8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
 

Sample Output

      
      
1 2 3

Hint

Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000). 
 给出n,m;代表n次操作,找出第m大的数,I代表输入,Q代表输出;
构建一个优先队列,从大到小排序,但队列中只保存m个数,这样每输出最上层的数字,就为第m大数学;
#include <iostream>
#include<queue>
#include<cstring>
#include<cstdio>
#include<vector>
using namespace std;
int n,m,k,sum=0;
char ch[10];
int main()
{
while(~scanf("%d%d",&n,&m))
{priority_queue<int,vector<int>,greater<int> >q;//优先队列,从大到小
	sum=0;
for(int i=0;i<n;i++)
{scanf("%s",ch);
	if(ch[0]=='I')//判断操作方式
	{scanf("%d",&k);
		q.push(k);
		sum++;//只存m个数
		if(sum>m)
		{q.pop();
		sum--;}
	}
	else
	printf("%d\n",q.top());
}
}}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值