Noj Red packet 1651 (二分)

  • [1651] Red packet

  • 时间限制: 1000 ms 内存限制: 65535 K
  • 问题描述
  • New Year is coming! Our big boss Wine93 will distribute some “Red Package”, just like Alipay and Wechat.

    Wine93 has m yuan, he decides to distribute them to n people and everyone can get some money(0 yuan is not allowed and everyone’s money is an integer), Now k people has gotten money, it’s your turn to get “Red Package”, you want to know, at least how much money to give you, then you can must become the “lucky man”. and the m yuan must be used out.

    Noting that if someone’s money is strictly much than others’, than he is “lucky man”.


  • 输入
  • Input starts with an integer T (T <= 50) denoting the number of test case.
    For each test case, three integers n, m, k (1 <= k < n <= 100000, 0< m <= 100000000) will be given.
    Next line contains k integers, denoting the money that k people get. You can assume that the k integers’ summation is no more than m.

  • 输出
  • Ouput the least money that you need to become the “lucky man”, if it is impossible, output “Impossible” (no quote).

  • 样例输入
  • 3

  • 3 5 2

  • 2 1

  • 4 10 2

  • 2 3

  • 4 15 2

  • 3 5

  • 样例输出
  • Impossible

  • 4

  • 6

  • #include<stdio.h>
    #include<string.h>
    #include<math.h>
    #include<algorithm>
    #define ll long long
    #define N 10010
    using namespace std;
    int main()
    {
    	int t,n,m,k,i,j,a;
    	scanf("%d",&t);
    	while(t--)
    	{
    		int sum=0;
    		int mm=0;
    		scanf("%d%d%d",&n,&m,&k);
    		for(i=0;i<k;i++)
    		{
    			scanf("%d",&a);
    			sum+=a;
    			mm=max(mm,a);
    		}
    		int s=m-sum;
    		int nk=n-k;
    		int nnk=nk-1;
    		int ss=s-nnk;
    		int ma=mm+1;
    		if(s-nnk<=mm)
    			printf("Impossible\n");
    		else
    		{
    			int l=ma,r=ss;
    			int mid;
    			while(l<=r)
    			{
    				mid=(l+r)/2;
    				if(mid<=ss-mid+1)
    					l=mid+1;
    				else
    					r=mid-1;
    			}
    			printf("%d\n",l);
    		}
    	}
    	return 0;
    }


     

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值