Light OJ 1067 Combinations (乘法逆元)

Description

Given n different objects, you want to take k of them. How many ways to can do it?

For example, say there are 4 items; you want to take 2 of them. So, you can do it 6 ways.

Take 1, 2

Take 1, 3

Take 1, 4

Take 2, 3

Take 2, 4

Take 3, 4

Input

Input starts with an integer T (≤ 2000), denoting the number of test cases.

Each test case contains two integers n (1 ≤ n ≤ 106), k (0 ≤ k ≤ n).

Output

For each case, output the case number and the desired value. Since the result can be very large, you have to print the result modulo 1000003.

Sample Input

3

4 2

5 0

6 4

Sample Output

Case 1: 6

Case 2: 1

Case 3: 15

乘法逆元:

#include<stdio.h>
#include<algorithm>
using namespace std;
#define ll long long 
ll f[1000010],a[1000010],k=1000003,i,j,x,y;
long long  exgcd(long long  a,long long b,ll&x,ll &y)//扩展欧几里得求逆元
{
if(b==0)
{
x=1;
y=0;
return a;
}
else
{ll gcd=exgcd(b,a%b,x,y);
ll temp=x;
x=y;
y=temp-a/b*y;
return gcd;
}
}
ll init()
{a[0]=1;
f[0]=1;
for(i=1;i<=1000000;i++)
{a[i]=a[i-1]*i%k;
exgcd(a[i],k,x,y);
f[i]=(x%k+k)%k;//求逆元
//printf("%lld %lld\n",a[i],f[i]);
}
}
int main()
{

     init();
     //printf("%d ",a[i]);
     int t;
     int cnt=0;
     scanf("%d\n",&t);
     int a1,b1;
     while(t--)
     {
        scanf("%d%d",&a1,&b1);
        long long ans=a[a1]*f[b1]%k*f[a1-b1]%k;
       printf("Case %d: %lld\n",++cnt,ans);
 
    }
 
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值