hdu4771 BFS Stealing Harry Potter's Precious (2013 Asia Hangzhou Regional Contest problem B)

题意:一个迷宫,里面最多4个宝物,从起点出发,求至少几步把宝物全拿到手

思路:先从每个宝物的位置做起点,做bfs,得出两两间最短距离,然后做一个暴力的旅行商问题就行了,数据量只有4个宝物,算法很好想,代码比较繁琐,认真仔细点就好,我自己做的时候WA了两次,sb错误。如果比赛的时候一起敲,应该能1A,或者少WA一次把。我写的BFS没啥大问题,后来检查出来一些小错都改正了,最后那个旅行商问题的处理,真是烦透了,脑子不太清醒,直接暴力了,后来continue写错位置还WA了,真是抓狂。


Stealing Harry Potter's Precious

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2493    Accepted Submission(s): 1140


Problem Description
  Harry Potter has some precious. For example, his invisible robe, his wand and his owl. When Hogwarts school is in holiday, Harry Potter has to go back to uncle Vernon's home. But he can't bring his precious with him. As you know, uncle Vernon never allows such magic things in his house. So Harry has to deposit his precious in the Gringotts Wizarding Bank which is owned by some goblins. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)..... A 3×4 bank grid is shown below:



  Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers' properties, so they live in the indestructible rooms and put customers' properties in vulnerable rooms. Harry Potter's precious are also put in some vulnerable rooms. Dudely wants to steal Harry's things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can't access the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry's precious are. He wants to collect all Harry's precious by as less steps as possible. Moving from one room to another adjacent room is called a 'step'. Dudely doesn't want to get out of the bank before he collects all Harry's things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry's precious.
 

Input
  There are several test cases.
  In each test cases:
  The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 100).
  Then a N×M matrix follows. Each element is a letter standing for a room. '#' means a indestructible room, '.' means a vulnerable room, and the only '@' means the vulnerable room from which Dudely starts to move.
  The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter's precious in the bank.
  In next K lines, each line describes the position of a Harry Potter's precious by two integers X and Y, meaning that there is a precious in room (X,Y).
  The input ends with N = 0 and M = 0
 

Output
  For each test case, print the minimum number of steps Dudely must take. If Dudely can't get all Harry's things, print -1.
 

Sample Input
  
  
2 3 ##@ #.# 1 2 2 4 4 #@## .... #### .... 2 2 1 2 4 0 0
 

Sample Output
  
  
-1 5
 

Source
 

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <stack>
using namespace std;
typedef long long LL;
const int INF=0x7fffffff-10000;
const int MAX_N=10000;

int N,M,n,fail;

char A[102][102];
int dis[102][102];
int juli[10][10];
int d[4][2]={0,1,0,-1,-1,0,1,0};
struct p{
    int x,y;
};
p P[10];

bool cango(int x,int y){
    if(A[x][y]!='#'&&x>0&&x<=N&&y>0&&y<=M){
        return 1;
    }
    else return 0;
}



queue<p>q;
void bfs(p a,int k){//起点是a,属于第k个要点
    for(int i=1;i<=N;i++){
        for(int j=1;j<=M;j++){
            dis[i][j]=INF;
        }
    }
    while(!q.empty()){
        q.pop();
    }
    q.push(a);
    int FIND=0;
    dis[a.x][a.y]=0;
    while(!q.empty()){
        p f=q.front();q.pop();

        for(int i=0;i<=n;i++){
            if(i==k)continue;
            if(f.x==P[i].x&&f.y==P[i].y){
                juli[k][i]=dis[f.x][f.y];
                juli[i][k]=juli[k][i];
                FIND++;
//                cout<<"find"<<endl;
            }
        }

        for(int i=0;i<4;i++){
            int nx=f.x+d[i][0];
            int ny=f.y+d[i][1];
            if(cango(nx,ny)&&dis[nx][ny]==INF){
                p e;
                e.x=nx;
                e.y=ny;
                q.push(e);
//                cout<<nx<<"&"<<ny<<endl;
                dis[nx][ny]=dis[f.x][f.y]+1;
            }
        }
    }
//    cout<<"find"<<FIND<<endl;
    if(FIND!=n)fail=1;

}


int baosou(int s){//最终结果的暴搜

}
int main(){
    while(cin>>N>>M&&N!=0){
        fail=0;
        memset(A,0,sizeof(A));
        memset(P,0,sizeof(P));
        memset(dis,0,sizeof(dis));
        memset(juli,0,sizeof(juli));//最后处理出的结果,0点是起点
        for(int i=1;i<=N;i++){
            for(int j=1;j<=M;j++){
                scanf(" %c",&A[i][j]);
                if(A[i][j]=='@'){
                    P[0].x=i;
                    P[0].y=j;
                }
            }
        }

//        cout<<P[0].x<<P[0].y<<endl;
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%d%d",&P[i].x,&P[i].y);
        }



        for(int i=0;i<n;i++){
            bfs(P[i],i);
        }
//        cout<<fail<<endl<<endl;
        if(fail==1){
            printf("-1\n");
        }
        else{
            int ans=INF;
            if(n==1){
                ans=juli[0][1];
            }
            if(n==2){
                ans=min(juli[0][1]+juli[1][2],juli[0][2]+juli[2][1]);
            }
            if(n==3){
                for(int i=1;i<=3;i++){
                    for(int j=1;j<=3;j++){
                        if(j==i)continue;
                        for(int k=1;k<=3;k++){
                            if(k==i||k==j)continue;
//                            cout<<i<<j<<k<<endl<<endl;
                            ans=min(juli[0][i]+juli[i][j]+juli[j][k],ans);
//                        cout<<i<<j<<k<<" "<<ans<<endl;
//                        cout<<juli[0][2]<<juli[2][3]<<juli[3][1]<<endl;
                        }
                    }
                }
            }
            if(n==4){
                for(int i=1;i<=4;i++){
                    for(int j=1;j<=4;j++){
                        if(j==i)continue;
                        for(int k=1;k<=4;k++){
                            if(k==i||k==j)continue;
                            for(int l=1;l<=4;l++){
                                if(l==i||l==j||l==k)continue;
                                ans=min(juli[0][i]+juli[i][j]+juli[j][k]+juli[k][l],ans);
                            }
                        }
                    }
                }
            }
            printf("%d\n",ans);
        }



    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值