hdu2141 Can you find it?(二分*)

Can you find it?

Time Limit : 10000/3000ms (Java/Other)   Memory Limit : 32768/10000K (Java/Other)
Total Submission(s) : 230   Accepted Submission(s) : 78
Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
  
  
Case 1: NO YES NO 【代码】
#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
int a[555],b[555],c[555],num[255555];
int main()
{
    int n,m,k,sum,t,max,i,j;
    int Case=1;
    while(scanf("%d%d%d",&n,&m,&k)!=EOF)
    {
        for(i=0;i<n;i++)
        scanf("%d",&a[i]);
        for(i=0;i<m;i++)
        scanf("%d",&b[i]);
        for(i=0;i<k;i++)
        scanf("%d",&c[i]);
        sort(c,c+k);
        int q=0;
        for(i=0;i<n;i++)//先把前两排的数加起来
        for(j=0;j<m;j++)
        num[q++]=a[i]+b[j];
        sort(num,num+q);//排序
        scanf("%d",&t);
        printf("Case %d:\n",Case++);
        while(t--)
     { 
        int bz=0;
        scanf("%d",&max);
        for(i=0;i<k;i++)
        {
            sum=max-c[i];
            int l=0;
            int r=q-1;
            int mid=(l+r)/2;
            while(l+1<r)//二分求
            {
                if(num[mid]>sum)
                r=mid;
                else if(num[mid]<sum)
                l=mid;
                else
                {
                    bz=1;
                    break;
                }
                mid=(l+r)/2;
            }
            if(num[l]==sum||num[r]==sum)
            {
                bz=1;
            }
            if(bz)
            {
            break;
            }
        }
        if(bz==0)
        printf("NO\n");
        else
        printf("YES\n");
     }
    }
    return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值