HDU 2141 Can you find it?(二分)

Problem Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

 

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

 

Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".

 

Sample Input

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10

 

Sample Output

Case 1:
NO
YES
NO

 

题意:

输入数据第一行是三个数,分别表示三个数组的大小.。接下来的三行是输入三个数组的大小。第四行输入一个整数n,表示接下来n行测试数据。每个测试数据是一个整数m,要求在上面的三个数组中每个数组中找一个数(共三个数)相加之和等于m。如果找到了就输出YES,如果不存在这样的三个数那么就输出NO.

 

思路:

因为题目每个数组最多有500个元素,所以如果三个for循环就是500*500*500则会超时

可以先将前两个数组任意两两相加构成一个新数组。将此数组排序。然后新数组和第三个数组相加,利用二分法,不断用得到的新数组中间数的和第三个数组的元素相加,直到得到x或者跳出循环为止。

 

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
	int l,m,n,o=1;
	while(cin>>l>>m>>n)
	{
	   int a[510],b[510],c[510],d[250010];
	   for(int i=0;i<l;i++)
	   cin>>a[i];
	   for(int i=0;i<m;i++)
	     cin>>b[i];
	   for(int i=0;i<n;i++)
	     cin>>c[i];
	   int k=0;
	   for(int i=0;i<l;i++)
       {
           for(int j=0;j<m;j++)
           {
               d[k++]=a[i]+b[j];
           }
       }
	   sort(d,d+k);
	   int s;
	   cin>>s;
	   cout<<"Case "<<o++<<":"<<endl;
	   while(s--)
	   {
		  int x;
		  cin>>x;
		  bool bb=false;
		  for(int i=0;i<n;i++)
		  {
		      int l=0,r=k-1;
		      while(l<=r)
              {
			     int mid=(l+r)/2;
			     if(d[mid]+c[i]==x)
			     {
				    bb=true;
				    break;
                 }
			     else if(d[mid]+c[i]<x)
			     {
				     l=mid+1;
			     }
			     else
			         r=mid-1;
              }
		      if(bb)
		        break;
		  }
		  if(bb)
		     cout<<"YES"<<endl;
		  else
		     cout<<"NO"<<endl;
	     }
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值