HDU 5512 Pagodas (GCD博弈 + 2015ACM/ICPC亚洲区沈阳站-重现赛)

传送门
Problem Description
n pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from 1 to n. However, only two of them (labelled a and b, where 1≤a≠b≤n) withstood the test of time.

Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled i (i∉{a,b} and 1≤i≤n) if there exist two pagodas standing erect, labelled j and k respectively, such that i=j+k or i=j−k. Each pagoda can not be rebuilt twice.

This is a game for them. The monk who can not rebuild a new pagoda will lose the game.

Input
The first line contains an integer t (1≤t≤500) which is the number of test cases.
For each test case, the first line provides the positive integer n (2≤n≤20000) and two different integers a and b.

Output
For each test case, output the winner (Yuwgna" orIaka”). Both of them will make the best possible decision each time.

Sample Input
16
2 1 2
3 1 3
67 1 2
100 1 2
8 6 8
9 6 8
10 6 8
11 6 8
12 6 8
13 6 8
14 6 8
15 6 8
16 6 8
1314 6 8
1994 1 13
1994 7 12

Sample Output
Case #1: Iaka
Case #2: Yuwgna
Case #3: Yuwgna
Case #4: Iaka
Case #5: Iaka
Case #6: Iaka
Case #7: Yuwgna
Case #8: Yuwgna
Case #9: Iaka
Case #10: Iaka
Case #11: Yuwgna
Case #12: Yuwgna
Case #13: Iaka
Case #14: Yuwgna
Case #15: Iaka
Case #16: Iaka

题目大意:
给定T组数据,每组数据有三个数 n,a,b,分别表示有n个塔:序号1-n,然后a,b就是已经固定的两个塔,通过已知的两个塔可以得到a+b,a-b两种塔其中的一个,然后两个和尚进行修建塔,两个人进行比赛,当一个和尚无法进行上述操作的时候就输了,输出赢的那一个。
解题思路:
其实这是个简单的GCD博弈,可以通过样例来计算得到规律,我们通过已知的a和b得到的是a+b,a-b,也就是GCD(a,b)的倍数。然后我们就是看1-n区间中有多少GCD(a,b)的倍数,然后减去2,判断一下奇偶就行拉。
My Code:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
using namespace std;
int GCD(int a, int b)
{
    if(b==0)
        return a;
    return GCD(b, a%b);
}
int main()
{
    int T;
    scanf("%d",&T);
    for(int cas=1; cas<=T; cas++)
    {
        int a, b, n;
        scanf("%d%d%d",&n,&a,&b);
        int tmp = n/GCD(a,b)-2;
        printf("Case #%d: ",cas);
        if(tmp&1)
            puts("Yuwgna");
        else
            puts("Iaka");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值