Pagodas
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 2116 Accepted Submission(s): 1448
Problem Description
n
pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from
1
to
n
. However, only two of them (labelled
a
and
b
, where
1≤a≠b≤n
) withstood the test of time.
Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled i (i∉{a,b} and 1≤i≤n) if there exist two pagodas standing erect, labelled j and k respectively, such that i=j+k or i=j−k . Each pagoda can not be rebuilt twice.
This is a game for them. The monk who can not rebuild a new pagoda will lose the game.
Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled i (i∉{a,b} and 1≤i≤n) if there exist two pagodas standing erect, labelled j and k respectively, such that i=j+k or i=j−k . Each pagoda can not be rebuilt twice.
This is a game for them. The monk who can not rebuild a new pagoda will lose the game.
Input
The first line contains an integer
t (1≤t≤500)
which is the number of test cases.
For each test case, the first line provides the positive integer n (2≤n≤20000) and two different integers a and b .
For each test case, the first line provides the positive integer n (2≤n≤20000) and two different integers a and b .
Output
For each test case, output the winner (``Yuwgna" or ``Iaka"). Both of them will make the best possible decision each time.
Sample Input
16 2 1 2 3 1 3 67 1 2 100 1 2 8 6 8 9 6 8 10 6 8 11 6 8 12 6 8 13 6 8 14 6 8 15 6 8 16 6 8 1314 6 8 1994 1 13 1994 7 12
Sample Output
Case #1: Iaka Case #2: Yuwgna Case #3: Yuwgna Case #4: Iaka Case #5: Iaka Case #6: Iaka Case #7: Yuwgna Case #8: Yuwgna Case #9: Iaka Case #10: Iaka Case #11: Yuwgna Case #12: Yuwgna Case #13: Iaka Case #14: Yuwgna Case #15: Iaka Case #16: Iaka
Source
显然能够建的的位置在gcd(a,b)的倍数上,所以能建的位置有n/gcd(a,b) - 2个,
判断奇偶因为%2,-2无影响
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <stack>
#include <cmath>
#include <queue>
#include <map>
using namespace std;
#define N 2100
int n,a,b;
int T;
int main()
{
scanf("%d",&T);
for(int i=1;i<=T;i++)
{
scanf("%d%d%d",&n,&a,&b);
int d=__gcd(a,b);
d=n/d;
if(d%2 == 0)
printf("Case #%d: Iaka\n",i);
else
printf("Case #%d: Yuwgna\n",i);
}
return 0;
}