hdu 5776 sum(BestCoder Round #85——思维题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5776

sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1030    Accepted Submission(s): 457


Problem Description
Given a sequence, you're asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO
 

Input
The first line of the input has an integer T ( 1T10 ), which represents the number of test cases. 
For each test case, there are two lines:
1.The first line contains two positive integers n, m ( 1n100000 1m5000 ).
2.The second line contains n positive integers x ( 1x100 ) according to the sequence.
 

Output
Output T lines, each line print a YES or NO.
 

Sample Input
  
  
2 3 3 1 2 3 5 7 6 6 6 6 6
 

Sample Output
  
  
YES NO
 

Source
 
题目大意:

给定一个数列,求是否存在连续子列和为m的倍数,存在输出YES,否则输出NO
解题思路:(官方题解)
预处理前缀和,一旦有两个数模m的值相同,说明中间一部分连续子列可以组成m的倍数。 另外,利用抽屉原理,我们可以得到,一旦n大于等于m,答案一定是YES 复杂度 O(n)
解释一下:
举个例子:
4%3=1
10%3=1
那么10-4=6是可以被3整除的。
也就是说只要这个余数出现过两次,那么必定存在一个连续的子序列可以组成m的倍数。

详见代码。
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int a[100000+10],vis[5010];

int main()
{
    int t,s,sum;
    scanf("%d",&t);
    while (t--)
    {
        sum=s=0;
        int n,m,flag=0;
        scanf("%d%d",&n,&m);
        memset(vis,0,sizeof(vis));
        vis[0]=1;
        for (int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
        }
        for (int i=1; i<=n; i++)
        {
            sum+=a[i];
            s=sum%m;
            if (vis[s]==1)
            {
                flag=1;
                break;
            }
            vis[s]=1;
        }
        if (flag==1)
            printf ("YES\n");
        else
            printf ("NO\n");
    }
    return 0;
}






  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值