poj2453------An Easy Problem 进制转换 水题

An Easy Problem
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7161 Accepted: 4236

Description

As we known, data stored in the computers is in binary form. The problem we discuss now is about the positive integers and its binary form.

Given a positive integer I, you task is to find out an integer J, which is the minimum integer greater than I, and the number of '1's in whose binary form is the same as that in the binary form of I.

For example, if "78" is given, we can write out its binary form, "1001110". This binary form has 4 '1's. The minimum integer, which is greater than "1001110" and also contains 4 '1's, is "1010011", i.e. "83", so you should output "83".

Input

One integer per line, which is I (1 <= I <= 1000000).

A line containing a number "0" terminates input, and this line need not be processed.

Output

One integer per line, which is J.

Sample Input

1
2
3
4
78
0

Sample Output

2
4
5
8
83

Source

POJ Monthly,zby03

 

#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<memory.h>
#include<math.h>
using namespace std;
int n,cc,num;
int s1[32],s2[32];
void zhuan()
{
    cc=0;
    int nn=n;
    num=0;
    while(nn)
    {
        s1[cc++]=nn&1;
        nn/=2;
    }
    int j=0;
    for(int i=cc-1;i>=0;i--)
    {
        s2[j++]=s1[i];
    }
    /*for(int i=0;i<cc;i++)
    cout<<s2[i];
    cout<<endl;*/
}
void solve()
{
    memset(s1,0,sizeof(s1));
    int i;
    for(i=cc-1;i>=0;i--)
    {
        if(s2[i]==1)
        break;
    }
    if(i==0)
    {
        s1[0]=1;
        cc++;
       // puts("!");
    }
    else
    {
        if(s2[i-1]==0)
        {
            for(int j=0;j<i-1;j++)
            s1[j]=s2[j];
            s1[i-1]=1;s1[i]=0;
            for(int j=i+1;j<cc;j++)
            s1[j]=s2[j];
            //puts("@");
        }
        else
        {
            int q=-1;
            while(s2[i]==1)
            {
                q++;
                i--;
                if(i<0)
                break;
            }
            if(i<0)
            {
                s1[0]=1;cc++;
                for(int j=cc-1;j>cc-1-q;j--)
                s1[j]=1;
                //puts("&");
            }
            else
            {
                for(int j=0;j<i;j++)
                s1[j]=s2[j];
                s1[i]=1;
                for(int j=cc-1;j>cc-1-q;j--)
                s1[j]=1;
                //puts("^");
            }
        }
    }
}
void solve2()
{
    int res=0;
    for(int i=0;i<cc;i++)
    {
        res+=s1[i]*pow(2,cc-1-i+0.0);
    }
    printf("%d\n",res);
}
int main()
{
    while(scanf("%d",&n)&&n)
    {
        if(n==1) {puts("2");continue;}
        zhuan();
        solve();
        /*for(int i=0;i<cc;i++)
        cout<<s1[i];
        cout<<endl;*/
        solve2();
    }
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值