[sicily online]1020. Big Integer

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Long long ago, there was a super computer that could deal with VeryLongIntegers(no VeryLongInteger will be negative). Do you know how this computer stores the VeryLongIntegers? This computer has a set of n positive integers: b1,b2,...,bn, which is called a basis for the computer.

The basis satisfies two properties:
1) 1 < bi <= 1000 (1 <= i <= n),
2) gcd(bi,bj) = 1 (1 <= i,j <= n, i ≠ j).

Let M = b1*b2*...*bn

Given an integer x, which is nonegative and less than M, the ordered n-tuples (x mod b1, x mod b2, ..., x mod bn), which is called the representation of x, will be put into the computer.

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains three lines.
The first line contains an integer n(<=100).
The second line contains n integers: b1,b2,...,bn, which is the basis of the computer.
The third line contains a single VeryLongInteger x.

Each VeryLongInteger will be 400 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

Output

For each test case, print exactly one line -- the representation of x.
The output format is:(r1,r2,...,rn)

Sample Input

2

3
2 3 5
10

4
2 3 5 7
13

Sample Output

(0,1,0)
(1,1,3,6)

题目分析:

第一次做时,本来想做个字符串模拟整型数据的加、减、乘、除、模运算,用了自己的库,所以把题目中的大整数和除数都用string来表示,然后用自己写的string取模,最后总是超时,看了别的大神的做法,原来除数没必要用string表示(因为小于1000),这样就不会超时了

#include<iostream>
#include<stdio.h>
#include<cmath>
#include<iomanip>
#include <vector>
#include <string>
#include <algorithm>
#include <sstream>
using namespace std;

string strMod(string x1,int x2)
{
	int num=0;
	for(string::size_type i=0;i<x1.size();i++)
	{
		num=num*10+(x1[i]-'0');
		num=num%x2;
	}
	//直接把int转化成string
	stringstream strStream;
	strStream<<num;
	string result=strStream.str();
	return result;
}

int main()
{
	int n;
	cin>>n;
	for(int i=0;i<n;i++)
	{
		int m;
		scanf("%d",&m);
		vector<int> data;
		int tmpStr;
		for(int j=0;j<m;j++)
		{
			cin>>tmpStr;
			data.push_back(tmpStr);
		}//end for
		string bigInteger;
		cin>>bigInteger;
		cout<<"(";
		for (int j=0;j<m-1;j++)
		{
			string tmp=strMod(bigInteger,data[j]);
			printf("%s,",tmp.c_str());
		}
		string tmp=strMod(bigInteger,data[m-1]);
		printf("%s)\n",tmp.c_str());
	}
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值