[sicily online]1001. Alphacode

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Alice and Bob need to send secret messages to each other and are discussing ways to encode their messages: Alice: "Let's just use a very simple code: We'll assign `A' the code word 1, `B' will be 2, and so on down to `Z' being assigned 26." Bob: "That's a stupid code, Alice. Suppose I send you the word `BEAN' encoded as 25114. You could decode that in many different ways!" Alice: "Sure you could, but what words would you get? Other than `BEAN', you'd get `BEAAD', `YAAD', `YAN', `YKD' and `BEKD'. I think you would be able to figure out the correct decoding. And why would you send me the word `BEAN' anyway?" Bob: "OK, maybe that's a bad example, but I bet you that if you got a string of length 500 there would be tons of different decodings and with that many you would find at least two different ones that would make sense." Alice: "How many different decodings?" Bob: "Jillions!" For some reason, Alice is still unconvinced by Bob's argument, so she requires a program that will determine how many decodings there can be for a given string using her code.

Input

Input will consist of multiple input sets. Each set will consist of a single line of digits representing a valid encryption (for example, no line will begin with a 0). There will be no spaces between the digits. An input line of `0' will terminate the input and should not be processed

Output

For each input set, output the number of possible decodings for the input string. All answers will be within the range of a long variable.

Sample Input

25114

1111111111

3333333333

0

Sample Output

6

89

1

 

题目分析:

这个题目就是解码,编码时把A编成1直到Z编成26,但是解码时不唯一,比如12可以解码成AB也可以解码成L,题目要求求出解码的个数。

第一眼看到这个题目时,把一些情况列出来,比如25114。2可以单独来看是B也可以和5组合起来看是Y。所以串“25114”的解码个数=“5114”的解码个数+“114”的解码个数。递归公式有了,用递归的话存在重叠子问题,所以用DP

特别注意的是有0的存在,以为只能是10和20  0不能单独存在。

代码如下:

#include<iostream>
#include<vector>
#include<string>
#include<algorithm>
using namespace std;

int stringToInt(string x)
{
	if(x.size()!=2)
		return -1;
	return (x[1]-'0')*10+(x[0]-'0');
}
int main()
{
	string input;
	while(cin>>input&&input!="0")
	{

		//考虑连续0挨着一起的情况
		bool flag=false;
		bool fal=false;
		for(string::size_type i=1;i<input.size();i++)
		{
			if(input[i]=='0')
			{
				if(flag)
				{
					cout<<0<<endl;
					fal=true;
					break;
				}
				else
				{
					flag=true;
				}///end else
			}//end if
			else flag=false;
		}//end for
		if(fal)continue;

		//反转数组元素,为了和下标对应
		reverse(input.begin(),input.end());

		vector<unsigned long long> record=vector<unsigned long long>(input.size());
		
		//单独处理0号元素
		record[0]=1;

		//单独处理1号元素
		if(input.size()>1)
		{
			int tmp=stringToInt(input.substr(0,2));
			if(tmp<=26&&tmp%10!=0)
				record[1]=2;
			else if(tmp<=26&&tmp%10==0)
				record[1]=1;
			else record[1]=1;
		}//end if

		//处理后面的元素
		for(string::size_type i=2;i<input.size();i++)
		{
			int tmp=stringToInt(input.substr(i-1,2));

			//分三种情况,情况一:1~26但不包括10和20;情况二:10和20;情况三:其他
			if(tmp<=26&&tmp%10!=0)
				record[i]=record[i-1]+record[i-2];
			else if(tmp<=26&&tmp%10==0)
			{
				record[i]=record[i-2];
				if(i+1<input.size())
					record[++i]=record[i-1];
			}
			else record[i]=record[i-1];
		}//end for
		cout<<record[input.size()-1]<<endl;
	}//end while
}//end main


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值