[sicily online]1047. Super Snooker

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

On one of my many interplanetary travels I landed on a beautiful little planet called Crucible. It was inhabited by an extremely peace-loving people who called themselves Snooks. They received me very gracefully and told me I had arrived at precisely the right time, as the biggest event of the year was just then taking place: the Super Snooker Championship. Of course I couldn’t decline an invitation to go and watch. 
That year the Super Snooker Championship was contested by two experienced Snooks universally ac-claimed as the best players on the planet: Stephanie McHendry and Joanna McHiggins. The game involved an immense rectangular table covered with green cloth and lined by edges two inches high, except in the four corners and in the middle of the longer sides where there were holes. On it were put a number of balls (from 6 up to as many as 25), each representing a value or certain number of points (anywhere from 2 to 1000, but numbered consecutively). Each player in turn tried to nudge the lowest valued ball left on the table into one of the holes on the edges of the table using a strange limb called a “kew”. If one succeeded, she was said to have “podded” the ball and the value of the podded ball was added to her score. 
But here is the strange thing: the object of the game was not to finish with more points than the opponent. No, being a people who loved peace above all else, the object for both players was to end up with an equal number of points. This presented a bit of a problem. It was very important to them to know if it was possible to finish equal given the score of both players and the values of the balls left on the table. For instance, with a score-line of 56–34 and three balls left with values 13, 14 and 15, it is impossible to reach equal end-scores. If there are five balls left with values 20–24, it is possible: 56 + 20 + 24 = 34 + 21 + 22 + 23 = 100. You are asked to write a program that helps the Snooks by calculating whether it is possible for two Super Snooker players to win their game by finishing equal, given a score-line and the range of values of the range of the remaining balls. 

Input

The input consists of a line containing the number of configurations N (0 ≤ N ≤ 10000) to be calculated. It is followed by N lines each containing two scores and the lowest and highest values of the remaining balls.

Output

The output consists of one line for each configuration with the string ‘possible’ or the string ‘not possible’, depending on whether it is possible or not to finish equal from the given configuration.

Sample Input

5
56 34 13 15
56 34 20 24
0 0 500 519
0 0 500 520
0 0 500 521

Sample Output

not possible
possible
possible
not possible
not possible

题目分析:

用穷举法,2^n的时间复杂度,超时。

网上一位大神的数学解法(http://blog.sina.com.cn/s/blog_7064e7850100yjg1.html)

假设,两人已有分数是x1和x2(假设x1>x2)剩余球的范围是min到max,现在假设给x1这个人其余的球的集合是sum1,那么x2这人的集合是sum2

因为min到max连续 则sum1+sum2=(min+max)(max-min+1)/2

还有sum1+a=sum2+b

通过这两个方程解出sum1*2=(min+max)(max-min+1)/2+x1-x2

则后面那个式子(min+max)(max-min+1)/2+x1-x2为偶数,且大于等于0(若小于0说明,把所有球给小积分的人都小于大积分的人)

现在解出了sum1,然后穷举当给sum1这人0个球到max-min+1个球的最大值,最小值情况

例如,给sum1  i个球时,sum1的取值范围是在(min+0)+(min+1)+……(min+i-1)到(max-i+1)……max

如果sum1满足其中一个i值,那么就成立

/*
*/
#include<iostream>
#include <iomanip>
#include<stdio.h>
#include<cmath>
#include<iomanip>
#include<list>
#include <map>
#include <vector>
#include <string>
#include <algorithm>
#include <sstream>
#include <stack>
#include<queue>
#include<string.h>
using namespace std;

int main()
{
	int n;
	scanf("%d",&n);
	for(int xx=0;xx<n;xx++)
	{
		int x1,x2,min,max;
		bool flag=false;
		long long sum1=0,sum2=0;//设sum1小于sum2
		scanf("%d%d%d%d",&x1,&x2,&min,&max);
		if(x1>x2)swap(x1,x2);
		long long tmp=(min+max)*(max-min+1)/2+x1-x2;
		if(tmp%2==1||tmp<0)//tmp小于0时表示,所有的都加到小的上面还没有上面大
		{
			printf("not possible\n");
			continue;
			//flag=false;
		}
		sum1=tmp/2;
		for(int i=0;i<=max-min+1;i++)
		{
			long long l=0,r=0;
			for(int j=0;j<i;j++)
			{
				l+=min+j;
				r+=max-j;
			}//end for j
			if(sum1>=l&&sum1<=r)
				flag=true;
		}
		if(flag)
			printf("possible\n");
		else printf("not possible\n");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值