This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
题意:输入两个系数为浮点型的多项式,输出两个多项式的和
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define maxn 1005
#define eps 1e-6
double sum[maxn];
int main()
{
int k;
scanf("%d",&k);
int x;
double y;
for(int i = 0; i < k; i ++)//输入第一个多项式
{
scanf("%d %lf",&x,&y);
sum[x] += 1.0*y;
}
scanf("%d",&k);
for(int i = 0; i < k; i ++)//输入第二个多项式
{
scanf("%d %lf",&x,&y);
sum[x] += 1.0*y;
}
int counts = 0;
for(int i = 1000; i >= 0; i --)
{
if(sum[i]>eps||sum[i]<-eps)//判断的时候不能忘了系数为负的情况
counts++;
}
printf("%d",counts);
for(int i = 1000; i >= 0; i --)
{
if(sum[i]>eps||sum[i]<-eps)//输出也是
printf(" %d %.1f",i,sum[i]);
}
return 0;
}