简单的杀人游戏 uva 133





Description

h1,h2,h3,h4,h5,h6{margin-bottom:0;}div.textBG p{margin: 0 0 0.0001pt;} Download as PDF
The Dole Queue
In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.


Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).


Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).


Sample input

10 4 3
0 0 0


Sample output

tex2html_wrap_inline34 4 tex2html_wrap_inline34 8, tex2html_wrap_inline34 9 tex2html_wrap_inline34 5, tex2html_wrap_inline34 3 tex2html_wrap_inline34 1, tex2html_wrap_inline34 2 tex2html_wrap_inline34 6, tex2html_wrap_inline50 10, tex2html_wrap_inline34 7

where tex2html_wrap_inline50 represents a space.

题意:就是说有n个人,然后一个顺时针数m个人,逆时针数k个人,并同时把他们送去进修,类似杀人吧,直接去掉就好了,最后没有人活,若顺逆指向同一个人,输出一次就好。//题目好像有点bug。最后的是怎么会是一个空格呢,我用两个AC掉了

思路:简单的循环,用了三个数组,一个原来的,一个逆时针,一个顺时针,直到最后没有人剩余;

AC 代码:

#include<stdio.h>
 int a[25];//源数组
 int n,m,k,t;
 int f(int i,int g,int *d){//在那个数组里隔几个杀人

        for(t=0;t<g;){
          for(;i<n;i++){
            if(a[d[i]-1]==0){continue;}
            t++;
            if(t==g){break;}
           }
           if(i>=n){i=0;}//所选数组已经到尽头重新开始数
        }
 return i;}
 int main(){
   int i,j,g,t;
   int b[25],c[25];//b是逆时针数组,c是顺时针数组
   while(scanf("%d%d%d",&n,&m,&k)!=EOF){
        if(n==0&&m==0&&k==0){break;}
        for(i=0;i<n;i++)
         {
          a[i]=i+1;
          c[i]=i+1;
          b[i]=n-i;
        }//赋值过程
       i=0;
       j=0;
       g=0;t=0;
   while(g<n)
    {
        i=f(i,m,c);
        j=f(j,k,b);
        a[c[i]-1]=0;
        a[b[j]-1]=0;
        if(t){printf(",");}
        t=1;
        if(c[i]==b[j]){//两个指向同一个人输出一个
             g++;
             printf("%3d",b[j]);
        }
        else {
            g+=2;
            printf("%3d",c[i]);
            printf("%3d",b[j]);
        }
    }
    printf("\n");
   }
return 0;
}

//这题有点类似约瑟夫问题,但还是坚持做出来了,wa了三四次,就是输出问题,第一次是应为输出直接错了,后来改了还是WA了,最后%3d过去了。。。。。。。

只要努力了就一定会有收获的,继续努力。。。。。。。



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值