[POJ 3368]Frequent values(RMQ)

Description

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4
3

Source

题目大意:给定一个不降序列a1....an,有q个询问,对于每个询问(i,j),输出区间[i,j]中连续相同的数字个数。

此题可以用RMQ解决,只需要对原序列进行O(n)的预处理,得到一个数组num,num[i]=前i个数字中,与第i个数字连续且相同的个数。然后对num数组进行RMQ即可。查询时需要稍微处理一下,因为如果直接把查询区间一分为二的话,中间的分界线可能会把一个连续相同的数字序列分割为二,这样求出来的答案可能比正确答案小。所以查询[L,R]区间时,要从L开始找到一个最大的T,使得[L,T)为一个完整的连续相同数字子序列,则问题的答案就是(T-L)和RMQ[T,R]的最大值

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>

#define MAXN 100100
#define mem(array,num) memset

using namespace std;

int n,q,f[MAXN][100],inNum[MAXN],num[MAXN]; //inNum[i]=输入的第i个数,num[i]=直到第i个数,和第i个数相连且相同的数的个数

void ST_RMQ()
{
    int m,k=(int)(log((double)n)/log(2.0));
    for(int i=1;i<=n;i++)
        f[i][0]=num[i];
    for(int j=1;j<=k;j++)
        for(int i=1;i+(1<<j)-1<=n;i++)
        {
            m=i+(1<<(j-1));
            f[i][j]=max(f[i][j-1],f[m][j-1]);
        }
}

int query_RMQ(int l,int r)
{
    if(l>r) return 0;
    int k=(int)(log((double)(r-l+1))/log(2.0));
    return max(f[l][k],f[r-(1<<k)+1][k]);
}

int main()
{
    while(1)
    {
        mem(inNum,0);
        mem(num,0);
        mem(f,0);
        scanf("%d",&n);
        if(!n) break;
        scanf("%d",&q);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&inNum[i]);
            if(inNum[i]==inNum[i-1]) num[i]=num[i-1]+1;
            else num[i]=1;
        }
        ST_RMQ();
        for(int i=1;i<=q;i++)
        {
            int L,R,t;
            scanf("%d%d",&L,&R);
            t=L;
            while(inNum[t]==inNum[t-1]&&t<=R) t++; //找到一个分界线t,使得t不分割一段相同且连续的数
            printf("%d\n",max(t-L,query_RMQ(t,R)));
        }
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值