莫比乌斯反演模板hdu1695

GCD

http://acm.hdu.edu.cn/showproblem.php?pid=1695

Description

Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs. Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases. Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.

Output

For each test case, print the number of choices. Use the format in the example.

Sample Input

2
1 3 1 5 1
1 11014 1 14409 9

Sample Output

Case 1: 9
Case 2: 736427

Hint

For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).

题意

给定的a-b和c-d区间中找两个数x和y使得GCD(x,y)=k;问有多少对这样的书。

解析

莫比乌斯反演模板题。

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<vector>
#include<queue>
#include<cmath>
#include<map>
#include<set>
#include<cstdlib>
#define inf 0x3f3f3f3f
using namespace std;
typedef long long ll;
const int maxn=100010;

int vis[maxn];
int prime[maxn];
int cnt;
int mu[maxn];
int sum[maxn];

void init()
{
    memset(vis,0,sizeof(vis));
    cnt=0;
    mu[1]=1;
    for(int i=2;i<maxn;i++)
    {
        if(!vis[i])
        {
            prime[cnt++]=i;
            mu[i]=-1;
        }
        for(int j=0;j<cnt&&i*prime[j]<maxn;j++)
        {
            vis[i*prime[j]]=1;
            if(i%prime[j])
                mu[i*prime[j]]=-mu[i];
            else
            {
                mu[i*prime[j]]=0;
                break;
            }
        }
    }
    sum[0]=0;
    for(int i=1;i<maxn;i++)
        sum[i]=sum[i-1]+mu[i];
}

int main()
{
    int a,b,c,d,k;
    init();
    int T,ca=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d%d%d",&a,&b,&c,&d,&k);
        printf("Case %d: ",ca++);
        if(k==0)
        {
            printf("0\n");
            continue;
        }
        b=b/k;
        d=d/k;
        if(b>d)
            swap(b,d);
        long long ans1=0;
        int last;
        for(int i=1;i<=b;i=last+1)
        {
            last=min(b/(b/i),d/(d/i));
            ans1+=(long long)(sum[last]-sum[i-1])*(b/i)*(d/i);
        }
        long long ans2=0;
        for(int i=1;i<=b;i=last+1)
        {
            last=b/(b/i);
            ans2+=(long long)(sum[last]-sum[i-1])*(b/i)*(b/i);
        }
        long long ans=ans1-ans2/2;
        printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值