POJ 1017 Packets (贪心)

Packets
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 43360
Accepted: 14612

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 

Source

Central Europe 1996


装箱问题  

    问题描述
    一个工厂制造的产品形状都是长方体,它们的高度都是h,长和宽都相等,一共有六个
型号,他们的长宽分别为 1*1, 2*2, 3*3, 4*4, 5*5, 6*6.  这些产品通常使用一个  6*6*h       

的长方体包裹包装然后邮寄给客户。因为邮费很贵,所以工厂要想方设法的减小每个订单运送时的
包裹数量。他们很需要有一个好的程序帮他们解决这个问题从而节省费用。现在这个程序由
你来设计。 
    输入数据 
    输入文件包括几行,每一行代表一个订单。每个订单里的一行包括六个整数,中间用空
格隔开,分别为 1*1 至6*6 这六种产品的数量。输入文件将以 6 个0 组成的一行结尾。 
    输出要求 
    除了输入的最后一行6 个0 以外,输入文件里每一行对应着输出文件的一行,每一行输
出一个整数代表对应的订单所需的最小包裹数。 
    输入样例
    0 0 4 0 0 1  
    7 5 1 0 0 0  
    0 0 0 0 0 0  
     
    输出样例 
    2  
    1  

    解题思路
    这个问题描述得比较清楚,我们在这里只解释一下输入输出样例:共有两组有效输入,
第一组表示有4 个3*3 的产品和一个6*6 的产品,此时4 个 3*3 的产品占用一个箱子,另外
一个 6*6 的产品占用 1 个箱子,所以箱子数是 2;第二组表示有7 个 1*1 的产品,5 个 2*2
的产品和1 个 3*3 的产品,我们可以把他们统统放在一个箱子中,所以输出是1。
    分析六个型号的产品占用箱子的具体情况如下:6*6的产品每个会占用一个完整的箱
子,并且没有空余空间;5*5  的产品每个占用一个新的箱子,并且留下 11 个可以盛放 1*1
的产品的空余空间;4*4 的产品每个占用一个新的箱子,并且留下5 个可以盛放2*2 的产品
的空余空间;3*3 的产品情况比较复杂,首先3*3 的产品不能放在原来盛有5*5 或者4*4 的

箱子中,那么必须为3*3 的产品另开新的箱子,新开的箱子数目等于3*3 的产品的数目除以
4  向上取整;同时我们需要讨论为3*3 的产品新开箱子时,剩余的空间可以盛放多少2*2 和
1*1 的产品(这里如果有空间可以盛放2*2 的产品,我们就将它计入2*2 的空余空间,等到
2*2  的产品全部装完,如果还有2*2  的空间剩余,再将它们转换成 1*1 的剩余空间)。我们
可以分情况讨论为3*3 的产品打开的新箱子中剩余的空位,共为四种情况:第一种,3*3 的
产品的数目正好是4 的倍数,所以没有空余空间;第二种,3*3 的产品数目是4 的倍数加1,
这时还剩 5 个2*2 的空位和7 个 1*1 的空位;第三种,3*3 的产品数目是4 的倍数加2,这
时还剩3 个2*2 的空位和6 个 1*1 的空位;第四种,3*3 的产品数目是4 的倍数加3,这时
还剩 1 个 2*2  的空位和5 个 1*1 的空位;处理完3*3  的产品,就可以比较一下剩余的2*2
的空位和2*2 产品的数目,如果产品数目多,就将2*2 的空位全部填满,再为2*2 的产品打
开新箱子,同时计算新箱子中 1*1 的空位,如果剩余空位多,就将2*2 的产品全部填入2*2
的空位,再将剩余的 2*2  的空位转换成 1*1 的空位;最后处理 1*1 的产品,比较一下 1*1
的空位与1*1 的产品数目,如果空位多,将1*1 的产品全部填入空位,否则,先将1*1 的空
位填满,然后再为 1*1 的产品打开新的箱子。


#include <iostream>
#include <algorithm>
using namespace std;

int main()
{
	int vis[6],x,y,t;
	int u[4]={0,5,3,1}; //表示vis[2]的剩余空间还可以装的vis[1]的个数。
	while(scanf("%d%d%d%d%d%d",&vis[0],&vis[1],&vis[2],&vis[3],&vis[4],&vis[5])!=EOF)
	{   
		if(vis[0]==0&&vis[1]==0&&vis[2]==0&&vis[3]==0&&vis[4]==0&&vis[5]==0)
                       break;
		t=vis[5]+vis[4]+(vis[2]+3)/4+vis[3];  (vis[2]+3)/4正好等于vis[2]除4向上取整。
		y=5*vis[3]+u[vis[2]%4];
		if(vis[1]>y) 
		  t=t+(vis[1]-y+8)/9;
		x=36*(t-vis[5])-vis[4]*25-vis[3]*16-vis[2]*9-vis[1]*4;
		if(vis[0]>x)
			t=t+(vis[0]-x+35)/36;
		printf("%d\n",t);
	} 
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值