POJ 2394 Checking an Alibi (最短路+Dijkstra)

Checking an Alibi
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6217 Accepted: 2257

Description

A crime has been comitted: a load of grain has been taken from the barn by one of FJ's cows. FJ is trying to determine which of his C (1 <= C <= 100) cows is the culprit. Fortunately, a passing satellite took an image of his farm M (1 <= M <= 70000) seconds before the crime took place, giving the location of all of the cows. He wants to know which cows had time to get to the barn to steal the grain.

Farmer John's farm comprises F (1 <= F <= 500) fields numbered 1..F and connected by P (1 <= P <= 1,000) bidirectional paths whose traversal time is in the range 1..70000 seconds (cows walk very slowly). Field 1 contains the barn. It takes no time to travel within a field (switch paths).

Given the layout of Farmer John's farm and the location of each cow when the satellite flew over, determine set of cows who could be guilty.

NOTE: Do not declare a variable named exactly 'time'. This will reference the system call and never give you the results you really want.

Input

* Line 1: Four space-separated integers: F, P, C, and M

* Lines 2..P+1: Three space-separated integers describing a path: F1,F2, and T. The path connects F1 and F2 and requires T seconds to traverse.

* Lines P+2..P+C+1: One integer per line, the location of a cow. The first line gives the field number of cow 1, the second of cow 2, etc.

Output

* Line 1: A single integer N, the number of cows that could be guilty of the crime.

* Lines 2..N+1: A single cow number on each line that is one of the cows that could be guilty of the crime. The list must be in ascending order.

Sample Input

7 6 5 8
1 4 2
1 2 1
2 3 6
3 5 5
5 4 6
1 7 9
1
4
5
3
7

Sample Output

4
1
2
3
4

Hint

INPUT DETAILS:

Fields/distances like this:
          6

      4------5

      |      |

     2|      |

      |      |

7-----1      |5

   9  |      |

     1|      |

      |      |

      2------3

OUTPUT DETAILS:

Any cow except cow 5 could have done it. Cow 5 would take 9 seconds to get to the barn.

Source

USACO 2005 March Silver

题意:有F个农场 C头牛,P条双向路 给出M秒前C头牛所在的农场位置 问 M后谁有可能到达1农场偷吃粮食。
思路:很纯粹的最短路问题,求出每牛到1农场的距离 再和M比较一下

代码:16~32MS
我是完全函数化的一个模板做的。
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
using namespace std;
#define M 501
#define INF 999999
#define min(a,b) (a<b?a:b)
int map[M][M],dis[M];
int P[110];
int n,m,f,p,c;
void Dijkstra()  //算法核心。
{
  bool cov[M];
  memset(cov,0,sizeof(cov));
  for(int i=1;i<=f;i++) dis[i]=(i==1?0:INF);
  for(int i=1;i<=f;i++)  //我是把起点也扔进去,不过就是多走一次循环。
  {
      int Min=INF,s;
      for(int y=1;y<=f;y++)
      if(!cov[y] && dis[y]<Min)
      {
          Min=dis[y];
          s=y;
      }
      cov[s]=1;
      for(int y=1;y<=f;y++)
      dis[y]=min(dis[y],dis[s]+map[s][y]);
  }
}
void Init()  //输入。
{
  int i,j,a,b,z;
  for(i=0;i<M;i++)
  for(j=0;j<M;j++)
  map[i][j]=(i==j?0:INF);
  scanf("%d%d%d%d",&f,&p,&c,&m);
  for(i=1;i<=p;i++)
  {
      scanf("%d%d%d",&a,&b,&z);
      map[a][b]=map[b][a]=min(map[a][b],z);
  }
  for(i=1;i<=c;i++)
    scanf("%d",&P[i]);
}
void output()  //输出。
{
    int i,j,n=0;
    for(i=1;i<=c;i++)
        if(dis[P[i]]<=m)
    {
        n++;
        P[i]=-1;
    }
    printf("%d\n",n);
    for(i=1;i<=c;i++)
        if(P[i]==-1)
        printf("%d\n",i);
}
int main()
{
    Init();
    Dijkstra();
    output();
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值