程序设计基础59 数学问题数列片段和

1104 Sum of Number Segments (20 分)

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10​5​​. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:

4
0.1 0.2 0.3 0.4

Sample Output:

5.00

一,思路问题

1,我的思路是先将总的片段和加起来乘以元素个数,然后依次相减,规律是第一个元素乘以N减去N-1次,第二个元素乘以N-1减去N-2次,以此类推。但是程序健壮性不强,易出错。

2,更好的方法是推出每一位的元素出现的次数,通过每一个长度的片段这个元素出现的次数容易得到,得出公式,第i位元素出现的次数为i*(N-i+1).

二,正确代码

#include<cstdio>
using namespace std;
const int max_n = 100100;
double arr[max_n];
int main() {
	int N = 0;
	double v = 0, ans = 0;
	scanf("%d", &N);
	for (int i = 1; i <= N; i++) {
		scanf("%lf", &v);
		ans += v*i*(N - i + 1);
	}
	printf("%.2f", ans);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值