2014ACM/ICPC亚洲区鞍山赛区现场赛E(hdu 5074)

Hatsune Miku

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 173    Accepted Submission(s): 133


Problem Description
Hatsune Miku is a popular virtual singer. It is very popular in both Japan and China. Basically it is a computer software that allows you to compose a song on your own using the vocal package.

Today you want to compose a song, which is just a sequence of notes. There are only m different notes provided in the package. And you want to make a song with n notes.


Also, you know that there is a system to evaluate the beautifulness of a song. For each two consecutive notes a and b, if b comes after a, then the beautifulness for these two notes is evaluated as score(a, b).

So the total beautifulness for a song consisting of notes a 1, a 2, . . . , a n, is simply the sum of score(a i, a i+1) for 1 ≤ i ≤ n - 1.

Now, you find that at some positions, the notes have to be some specific ones, but at other positions you can decide what notes to use. You want to maximize your song’s beautifulness. What is the maximum beautifulness you can achieve?
 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains two integers n(1 ≤ n ≤ 100) and m(1 ≤ m ≤ 50) as mentioned above. Then m lines follow, each of them consisting of m space-separated integers, the j-th integer in the i-th line for score(i, j)( 0 ≤ score(i, j) ≤ 100). The next line contains n integers, a 1, a 2, . . . , a n (-1 ≤ a i ≤ m, a i ≠ 0), where positive integers stand for the notes you cannot change, while negative integers are what you can replace with arbitrary notes. The notes are named from 1 to m.
 

Output
For each test case, output the answer in one line.
 

Sample Input
  
  
2 5 3 83 86 77 15 93 35 86 92 49 3 3 3 1 2 10 5 36 11 68 67 29 82 30 62 23 67 35 29 2 22 58 69 67 93 56 11 42 29 73 21 19 -1 -1 5 -1 4 -1 -1 -1 4 -1
 

Sample Output
  
  
270 625
 

题意:给你n,m,分别代表一首歌的音符总数和可以选择的音符种类,然后给你m*m的矩阵,M(ij)代表如果i音符在j音符前的得分,然后再输入n个数字,正数代表该音符不能改变,负数则代表该音符可以为任一音符,最后让你求出最大的得分。

做法:比较简单的dp,刚刚接触dp,还不怎么会。用dp[i][j]来记录,i代表已经弄好的音符数,j代表目标点。分类考虑一下就ok。

#include <iostream>
#include <cstdio>
#include <climits>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <algorithm>
#include<ctime>
#define esp 1e-6
#define LL  long long
#define inf 0x0f0f0f0f
using namespace std;
int main()
{
    int t;
    int i,j,k;
    int n,m,ans;
    int num[105];
    int map[105][105];
    int dp[105][105];
    scanf("%d",&t);
    while(t--)
    {
        ans=0;
        scanf("%d%d",&n,&m);
        for(i=1;i<=m;i++)
            for(j=1;j<=m;j++)
            scanf("%d",&map[i][j]);
        for(i=1;i<=n;i++)
            scanf("%d",&num[i]);
        memset(dp,0,sizeof(dp));
        for(i=2;i<=n;i++)
        {
            if(num[i]!=-1)
            {
                if(num[i-1]!=-1)
                    dp[i][num[i]]=max(dp[i][num[i]],dp[i-1][num[i-1]]+map[num[i-1]][num[i]]);
                else
                {
                    for(j=1;j<=m;j++)
                      dp[i][num[i]]=max(dp[i][num[i]],dp[i-1][j]+map[j][num[i]]);
                }
            }
            if(num[i]==-1)
            {
                if(num[i-1]!=-1)
                {
                    for(j=1;j<=m;j++)
                        dp[i][j]=max(dp[i][j],dp[i-1][num[i-1]]+map[num[i-1]][j]);
                }
                else
                {
                    for(j=1;j<=m;j++)
                        for(k=1;k<=m;k++)
                    {
                        dp[i][k]=max(dp[i][k],dp[i-1][j]+map[j][k]);
                    }
                }
            }
        }
        ans=0;
        for(i=1;i<=m;i++)
            ans=max(ans,dp[n][i]);
     printf("%d\n",ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值