UVA 550 (13.07.26)

 Multiplying by Rotation 

Warning: Not all numbers in this problem are decimal numbers!


Multiplication of natural numbers in general is a cumbersome operation. In somecases however the product can be obtained by moving the last digit to the front.


Example: 179487 * 4 = 717948


Of course this property depends on the numbersystem you use, in the aboveexample we used the decimal representation. In base 9 we have a shorter example:


17 * 4 = 71 (base 9)


as (9 * 1 + 7) * 4 = 7 * 9 + 1

Input 

The input for your program is a textfile. Each line consists of three numbers separated by a space:the base of the number system, the least significant digit of the first factor, and the second factor.This second factor is one digit only hence less than the base. The input file ends with the standardend-of-file marker.

Output 

Your program determines for each input line the number of digits of the smallest first factor withthe rotamultproperty. The output-file is also a textfile. Each line contains the answer for thecorresponding input line.

Sample Input 

10 7 4
9 7 4
17 14 12

Sample Output 

6
2
4

题意: 输入的三个数中, 第一个数为进制数, 第二个数为尾数, 第三个数是乘数

要求的是, 找出某个数, 它的尾数是我们输入的第二个数, 然后 它乘以第三个数后的得数, 是该数的尾数移到首端所得的个数

例如179487 * 4 = 717948

进制10的背景下, 尾数为7, 乘数为4,  所得的得数, 你会发现它的结果只是将尾数移到首端而已

我们要做的是找到这样的一个数, 但是不是输出这个数, 是输出这个数的位数, 179487, 是6, 故答案为6~


数论的题目, 代码很水, 但是方法很牛叉:

给出AC代码:

#include<stdio.h>

int main() {
	int base, last, mul;
	int t1, t2, sum;
	int count;
	while(scanf("%d %d %d", &base, &last, &mul) != EOF) {
		count = 1;
		sum = last * mul;
		while(sum != last) {
			t1 = sum/base;
			t2 = sum%base;
			sum = mul * t2 + t1;
			count++;
		}
		printf("%d\n", count);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值